SparkFun Forums 

Where electronics enthusiasts find answers.

I am having trouble getting some load sensors to work with my raspberry pi. I am going off some instructions I found on GitHub, but every time I run It says to "Put known weight on the scale and then press Enter", and when I do that it says "Cannot calculate mean value. Try debug mode. Variable reading: 0"

The current connection is:

VCC -- 5v


DATA -- Pin 21

CLK -- Pin 20

I have tried using 3.3v also since the datasheet for the hx711 said it was fine to no avail. I also tried running a different HX711 code that still gave me 0. I even changed to GPIO Pins 5 and 6 (Both within the code and physically with the same result)

I also tried switching the red and white wires that run from my load sensor into the combinator boards combinator board since the electrical diagram said sometimes the red and white wires may have switched the red and white wire on the combinator board. I put the link that said that below ... 1560690169

Maybe the HX711 I purchased and the code I'm trying to use aren't compatible since it references a dout and a sck pin, but the HX711 read DATA and CLK. I have seen other models of the HX711 that read dout and sck.

Any help would be very much appreciated

My setup is:


4 Load Sensors:

Load Combinator:

Code (under python3 folder):
Hi jbecerr1,

While we cannot help with code that SparkFun did not write and verify, we would be happy to help identify any possible hardware issues in your circuit. Can you please take a few photos of the Load Cell Combinator Board, the HX711 Breakout and the circuit you have them in? Especially any soldering you have done. That will help us see if it is a problem with the circuit.
Thanks for taking those photos. I think I see the issue here. You need to have both Vcc and Vdd connected to your Pi's 3.3V pin. Vdd only sets the logic level so you can either tie it to Vcc or run it to a separate 3.3V pin since the Pi runs at 3.3V logic. Vcc is the supply voltage for the HX711 so that needs to be connected to 3.3V here.

That should fix the issue but if not, let us know and we can troubleshoot further.