Question for site Admins (no MX records)

General suggestions or questions about the SparkFun Electronics website

Moderators: phalanx, CS Paul

Post Reply
mprowe
Posts: 12
Joined: Wed Oct 21, 2015 9:11 am

Question for site Admins (no MX records)

Post by mprowe » Thu Oct 22, 2015 2:10 pm

Is this deliberate (see below) or do I have to turn off my spam filters?

Regards, Martin
~~~~~~~~~~~~~~~~~~~~~~~~

Code: Select all

10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: [192.168.0.12:25] connection accepted from [67.202.61.130:38593]
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set smtp greeting to [mailhost.peritonlane.net]
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Greylist disabled
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set max data size to 102400 KB
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set max received headers to 30
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Maximum recipient count set to 1000
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Wait for processing response at least 5 seconds
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: STARTTLS extension allowed
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: 8BIT MIME accepted
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: BINARY DATA extension allowed
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: PIPELINING extension allowed
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set local delivery to all
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set remote delivery to auth
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Greylist disabled
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set max data size to 102400 KB
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set max received headers to 30
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Maximum recipient count set to 1000
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Wait for processing response at least 5 seconds
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: STARTTLS extension allowed
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: 8BIT MIME accepted
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: BINARY DATA extension allowed
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: PIPELINING extension allowed
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set local delivery to all
10-22 21:52:38 +0100 08 mailhost SMTP-IN:00000181: Set remote delivery to auth
10-22 21:52:38 +0100 08 mailhost DNR:00000181: Search MX for 'forum.sparkfun.com'
10-22 21:52:38 +0100 08 mailhost DNR:00000181: Sending query (1/1) to 192.168.0.12:53
10-22 21:52:38 +0100 08 mailhost DNR:00000181: Search NS for 'forum.sparkfun.com'
10-22 21:52:38 +0100 08 mailhost DNR:00000181: forum.sparkfun.com found in cache
10-22 21:52:38 +0100 08 mailhost DNR:00000181: Sending query (1/1) to 205.251.194.60:53
10-22 21:52:39 +0100 08 mailhost DNR:00000181: 'forum.sparkfun.com' not found in DNS
10-22 21:52:39 +0100 02 mailhost SMTP-IN:00000181: Unable to determine MX associated with <forum.sparkfun.com>
10-22 21:52:39 +0100 08 mailhost SMTP-IN:00000181: Set smtp action to REJECT
10-22 21:52:39 +0100 08 mailhost SMTP-IN:00000181: Set smtp explanation to [Sender domain <forum.sparkfun.com> has no DNS MX entry]
10-22 21:52:39 +0100 08 mailhost SMTP-IN:00000181: Set mail state to REMOVED
10-22 21:52:39 +0100 08 mailhost SMTP-IN:00000181: closing session from [67.202.61.130:38593]

Valen
Support Volunteer
Posts: 1635
Joined: Wed Dec 22, 2010 2:05 am

Re: Question for site Admins (no MX records)

Post by Valen » Fri Oct 23, 2015 10:32 am

Can you be more specific as to what this log is about? What generated it, and what are you worried about? What does this have to do with SparkFun's site/servers? I mean, why are you trying to resolve MX records (references to mailservers) of forum.sparkfun.com?

mprowe
Posts: 12
Joined: Wed Oct 21, 2015 9:11 am

Re: Question for site Admins (no MX records)

Post by mprowe » Fri Oct 23, 2015 1:26 pm

Hi Valin,

My (and many other) email serves will reject emails (as an anti-spam filter) from sources that do not have valid DNS records.
Not that it worries me, I was just trying to be helpful. If I think that I am expecting any mail from "<whoever>@forum.sparkfun.com", I will just have to turn off the "Reject message if originator's domain has no MX entry" at my mail server.

If others are not getting emails from forum.sparkfun.com, maybe this is the reason?

Best regards, Martin

User avatar
darrellg
Posts: 294
Joined: Fri Oct 17, 2014 10:02 am
Location: Southern California

Re: Question for site Admins (no MX records)

Post by darrellg » Fri Oct 23, 2015 1:45 pm

Emails from the forum come from sparkfun.com, not forum.sparkfun.com.

puckettgw
Posts: 4
Joined: Fri Oct 23, 2015 2:56 pm

Re: Question for site Admins (no MX records)

Post by puckettgw » Fri Oct 23, 2015 3:03 pm

MX records are used to designate the inbound mail server for a given domain.
Forum.sparkfun.com does not receive (or send) mail.

Messages from the forums come from a sparkfun.com domain, not forum.sparkfun.com
Thus, spam filters check the MX records for sparkfun.com (because domains that send mail and don't receive it are probably spammy!)

Don't worry, you don't need to change your spam filters.

Valen
Support Volunteer
Posts: 1635
Joined: Wed Dec 22, 2010 2:05 am

Re: Question for site Admins (no MX records)

Post by Valen » Fri Oct 23, 2015 4:05 pm

darrellg wrote:Emails from the forum come from sparkfun.com, not forum.sparkfun.com.
That is true if you look at the Sender field, but in the header of the topic reply notifications I did notice (just now) a bunch of field with the following adress:
So technically the forum.sparkfun.com subdomain is used for some email purpose. And mprowe's mailserver seems to trip over this. I don't know why this is, or isn't by the spamfilter of my emailserver (hosted, not privately managed). I receive messages from sparkfun's forum normally. I can't help here, but did found the initial message to be somewhat lacking in stating the problem. Thus I asked for clarification.

puckettgw
Posts: 4
Joined: Fri Oct 23, 2015 2:56 pm

Re: Question for site Admins (no MX records)

Post by puckettgw » Sat Oct 24, 2015 3:33 pm

That's true, thank you for providing further information!
Mail servers running exim probably do trip over this. This seems to be an issue with phpBB configuration.
Hopefully Sparkfun's system administrators take a look into that ;)

puckettgw
Posts: 4
Joined: Fri Oct 23, 2015 2:56 pm

Re: Question for site Admins (no MX records)

Post by puckettgw » Sat Oct 24, 2015 3:39 pm

This problem should be resolved now -- thank you both for your time and effort in reporting the issue :)

Post Reply