Anyone else getting sent bare MCUs?

General suggestions or questions about the SparkFun Electronics website

Moderators: phalanx, CS Paul

Post Reply
Copper Dog
Posts: 2
Joined: Sat May 16, 2015 8:30 am

Anyone else getting sent bare MCUs?

Post by Copper Dog » Sat May 16, 2015 8:50 am

Hi all, hate for my first post on the forum to be negative but has anyone else ordered a boot loaded MCU from SparFun but received a bare one? I ordered a 328P a while back and it simply wouldn't take an upload. After much frustration I eventually ran a chip detector sketch on it to learn it was bare. In addition the chip pulls 90mA just sitting there compared to a chip out of a Uno that draws 20mA with the same sketch. Whats up with that ? I configured it to run an internal oscillator, killed the ADC and SPI and it still sucks 90mA doing nothing in a bare minimum circuit. It's pretty much useless.

Yeah I figured it out and yes it didn't cost much but was this the only chip that went out this way?

User avatar
Ross Robotics
Support Volunteer
Posts: 2007
Joined: Thu Jun 07, 2012 9:33 pm
Contact:

Re: Anyone else getting sent bare MCUs?

Post by Ross Robotics » Mon May 18, 2015 10:23 am

Sounds like an ESD issue.. I've never heard of that issue until now.
------------------------------------------------------------------------------------------------------------------------------------------------------------
//codlink
Available for circuit and PCB design, just PM me!

Copper Dog
Posts: 2
Joined: Sat May 16, 2015 8:30 am

Re: Anyone else getting sent bare MCUs?

Post by Copper Dog » Wed May 20, 2015 6:26 am

Hmm, hadn't considered that. I'm pretty careful but that doesn't mean it didn't get zapped or even zapped before it got to me. You may be right.

Post Reply