Search function problem sparkfun.com

General suggestions or questions about the SparkFun Electronics website

Moderators: phalanx, CS Paul

Post Reply
RonBurke
Posts: 4
Joined: Thu May 07, 2015 7:31 pm

Search function problem sparkfun.com

Post by RonBurke » Fri May 08, 2015 5:17 pm

I have an issue with sparkfun.com I have never encountered before. Some time ago I searched for the term "audio." Ever since, every single page that opens on your site has that word entered in the search box and the page obscured by a long list of suggested results. To read the page I have to click the search box, select the contents, delete. Every single page! It's so annoying it has really dissuaded me from ordering from sparkfun. I have tried deleting your cookies, setting to accept no cookies, clearing cache and history. It's always there. Doesn't matter whether I'm logged in or not. There's no problem with any other site. The issue exists with Firefox (37) and Chrome (42) but not with IE 11. I normally use Firefox and don't want to change browsers just to shop at sparkfun.

What's up with this? Any ideas?

User avatar
Ross Robotics
Support Volunteer
Posts: 2007
Joined: Thu Jun 07, 2012 9:33 pm
Contact:

Re: Search function problem sparkfun.com

Post by Ross Robotics » Sat May 09, 2015 2:12 pm

That's a first. Just tried it and it doesn't happen to me using Firefox.. It sounds like a setting. Check your profile settings..
------------------------------------------------------------------------------------------------------------------------------------------------------------
//codlink
Available for circuit and PCB design, just PM me!

RonBurke
Posts: 4
Joined: Thu May 07, 2015 7:31 pm

Re: Search function problem sparkfun.com

Post by RonBurke » Sat May 09, 2015 7:13 pm

It's a first for me, too. It's not obvious how it's even possible. I didn't see anything in Profile that could be related. (And every time I move from Settings to Profile to Orders to Addresses, etc., I get a long list of suggestions for "audio." Firefox and Chrome afflicted. Internet Explorer not.

User avatar
Ross Robotics
Support Volunteer
Posts: 2007
Joined: Thu Jun 07, 2012 9:33 pm
Contact:

Re: Search function problem sparkfun.com

Post by Ross Robotics » Sat May 09, 2015 10:06 pm

Can you take a screenshot of what you're seeing?
------------------------------------------------------------------------------------------------------------------------------------------------------------
//codlink
Available for circuit and PCB design, just PM me!

RonBurke
Posts: 4
Joined: Thu May 07, 2015 7:31 pm

Re: Search function problem sparkfun.com

Post by RonBurke » Sun May 10, 2015 11:06 am

Here are three screen shots in a composite.
Top--After entering sparkfun.com in address bar and opening.
Center--After selecting and deleting "audio" from search box.
Bottom--After clicking New Products.

Mysterious. I'm going to keep looking. It seems odd that it affects only Sparkfun.
Attachments
sparkfun_comp.png
3_screen_shots

RonBurke
Posts: 4
Joined: Thu May 07, 2015 7:31 pm

Re: Search function problem sparkfun.com

Post by RonBurke » Sun May 10, 2015 11:23 am

Hooray! I found it. I use Lastpass and it was (for some reason) filling the search box as a form fill. It's fixed. It didn't affect IE because it doesn't accept automatic fills. If it had affected more than just one site I might have found it sooner. I'll let Lastpass know about it since it wasn't set to record form contents.

Thanks for your replies. Just keeping me working on it helped a lot.

Post Reply