Thumbnails / Lightbox Modal Bug

General suggestions or questions about the SparkFun Electronics website

Moderators: phalanx, CS Paul

Post Reply
skittlebit
Posts: 3
Joined: Sat May 12, 2012 4:30 pm

Thumbnails / Lightbox Modal Bug

Post by skittlebit » Mon Dec 09, 2013 4:13 pm

When viewing a product, the images of the product show up in a medium sized preview as well as a set of smaller sized thumbnails. Clicking through the thumbnails changes the image in the medium sized preview -- but it also queues up a bunch of transitions in the large image modal (which appears after clicking the medium sized image).

That means that if you click thumbnail 2, 3, 4, 2, the large image upon opening immediately changes to image 2, then 3, then 4, then back to 2, and then finally sits still.

It would be awesome if this thumbnail-click-transition was disabled so the images don't dance around every time I try to view the large version (since I tend to go thru the thumbs first typically).

CS Paul
Posts: 128
Joined: Fri Apr 02, 2010 7:37 am

Re: Thumbnails / Lightbox Modal Bug

Post by CS Paul » Tue Dec 10, 2013 8:07 pm

Thanks for the note - a fix has been pushed. Let me know if you're seeing anything further.

notexactly
Posts: 13
Joined: Thu Jul 04, 2013 11:55 pm

Re: Thumbnails / Lightbox Modal Bug

Post by notexactly » Wed Dec 11, 2013 4:39 pm

I'm still seeing the same behavior. I also don't like how it automatically advances because it often does so while I'm examining details.

User avatar
Ross Robotics
Support Volunteer
Posts: 2007
Joined: Thu Jun 07, 2012 9:33 pm
Contact:

Re: Thumbnails / Lightbox Modal Bug

Post by Ross Robotics » Thu Dec 12, 2013 10:18 am

Same thing happens to me while I'm examining the pictures. It advances and I have to keep going back. The only work around is to keep the pointer on the back arrow. That stops it from moving.
------------------------------------------------------------------------------------------------------------------------------------------------------------
//codlink
Available for circuit and PCB design, just PM me!

Kamiquasi
Posts: 113
Joined: Sat Jan 15, 2011 4:46 pm

Re: Thumbnails / Lightbox Modal Bug

Post by Kamiquasi » Thu Dec 12, 2013 10:54 am

It eventually stops moving around (depending on just how often you clicked the tiny previews) - but it's fixed, just hasn't been deployed yet :) Soon!

Post Reply