Store image display oddity

General suggestions or questions about the SparkFun Electronics website

Moderators: phalanx, CS Paul

Post Reply
Pirtnac
Posts: 1
Joined: Fri Oct 19, 2012 8:12 pm

Store image display oddity

Post by Pirtnac » Fri Oct 19, 2012 8:37 pm

Hi there, here's a rather odd issue I caught just before bed. Did some brief testing, doesn't seem related to my browser (tried an old firefox, new chrome, internet explorer) so it might show up for others.

Issue: The pre / next arrows on full size images may not show up properly on all images, depending on what image was clicked to get the expanded image window.

Reproduction:
-go to https://www.sparkfun.com/products/11461
-click on 2nd image (connecter alone, no quarter. That should get the slightly larger product image embedded in the page to swap
-click the slightly larger image, opening up the full size floating... thing
-right side clicky to go to the next image exists when moused over, left side clicky to go back to the first image does not.
-first click to advance takes you to another copy of the same image (#2 on this page), 2nd click takes you to #3 (connector with quarter)
-the first image (bag of connectors) isn't reachable, unless it is the image selected on the store page.

Workaround: Just click the first image and get it's full size version, then the display works normally.

Notes: Other products pages are doing the same thing. https://www.sparkfun.com/products/11316 (two images) will not show the first if you start with the second, and the left / right buttons will go between two copies of the 2nd image.

I think whatever script generates the floating image is considering whatever image you start with the "first" in series (overwriting the real first image in the display sequence), and then adding the rest in sequence. It'id explain the double image, lack of first image when not expanding from the first, and how it works "properly" when you do click on the first.

Bed time!

Post Reply