SparkFun Forums 

Where electronics enthusiasts find answers.

General suggestions or questions about the SparkFun Electronics website
By pmscientist
Are you using the HTTPS Everywhere plugin? If so, try disabling the Sparkfun rule for HTTPS Everywhere. I was having this same issue with both news and tutorial pages, that fixed it for me.

SF: Looks to me like the majority of content from does get encrypted successfully when using HTTPS Everywhere. Based on a packet capture, when making a request for a news page there is a handful of encrypted traffic, and then an unencrypted GET for /news/view, which is what appears to cause the 404. Not sure where that URL came from, as don't see it in the page source, and the preceding packets are encrypted. It works totally fine when I disable the HTTPS Everywhere rule, though I still don't see a reference to /news/view in the page source. Hopefully that helps. It would be nice to use HTTPS Everywhere, but the important parts are encrypted, so no big deal to me.