Post your SparkFun.com bugs and issues here!

General suggestions or questions about the SparkFun Electronics website

Moderators: phalanx, CS Paul

User avatar
Erik
SFE Guru
Posts: 18
Joined: Tue Nov 16, 2010 10:36 am

Re: Post your SparkFun.com bugs and issues here!

Post by Erik » Thu Nov 18, 2010 9:44 am

roach wrote:Can't add an item to a wish list if it's out of stock (specifically http://www.sparkfun.com/commerce/produc ... ts_id=9261).

Also, where did the "Notify me when more items are in stock" feature go? I rely heavily on this!
This (i.e. both your issues) has now been fixed. Thanks!

stilldavid
Posts: 14
Joined: Tue Sep 11, 2007 1:26 pm
Contact:

Re: Post your SparkFun.com bugs and issues here!

Post by stilldavid » Thu Nov 18, 2010 10:09 am

bricogeek wrote:It seems all URL pointing to http://www.sparkfun.com/commerce/ shows a 404 page.
Put a redirect in yut htaccess for that and also make a custome 404 document.

Also some little suggestions:
- Put avaliable stock (in numbers) in the category list (not only in the product page)
- Put a downloadable PDF of the invoice in order history :)

Anyway, nice work!
Not everything pointed to /commerce/ 404s. Most all old links to products, tutorials, news posts and a host of other things redirect properly. Do you have a specific page you can point me to? I'll work on getting better 404s for truly broken /commerce/ links.

We did have the stock numbers visible in the category list for a while, but people complained that it was too cluttered. I think the icon showing the availability is sufficient, but we might revisit this.

We're about done with a pretty solid print stylesheet for order history, and I believe a PDF is coming soon too...

Thanks :)

stilldavid
Posts: 14
Joined: Tue Sep 11, 2007 1:26 pm
Contact:

Re: Post your SparkFun.com bugs and issues here!

Post by stilldavid » Thu Nov 18, 2010 10:16 am

fll-freak wrote:Wishlist, backorder, do not work from here:
http://www.sparkfun.com/products/10020
Thanks for the heads up! Can you give me any info about which browser version and operating system you're on?

stilldavid
Posts: 14
Joined: Tue Sep 11, 2007 1:26 pm
Contact:

Re: Post your SparkFun.com bugs and issues here!

Post by stilldavid » Thu Nov 18, 2010 11:46 am

follower wrote:In Chrome (version 7.0.517.44) the search that is initiated by typing "sparkfun.com" and pressing tab now fails as it uses this URL:

http://www.sparkfun.com/commerce/advanc ... n=products

rather than:

http://www.sparkfun.com/search/results? ... t=products

And it appears this isn't the only instance:

http://www.google.com/search?q=sparkfun ... result.php

http://www.google.com/search?q=%22spark ... ult.php%22

I assume it's because there's no redirects set up from the old search URLs?

--Philip;
Both copies of Google Chrome I tested (versions 6.0.472.63, 7.0.517.44) and Chromium Browser (7.0.517.41) are now up-to-date with the current search schema.

Why people link to search results, I have no idea. But then I guess I shouldn't be surprised. A redirect is now in place.

nmushov
Posts: 5
Joined: Tue Nov 16, 2010 9:13 am

Re: Post your SparkFun.com bugs and issues here!

Post by nmushov » Thu Nov 18, 2010 7:33 pm

Tracking numbers are no longer showing up in shipment emails.

Great job on the site!

Regards,
Nick

mattmoss
Posts: 2
Joined: Sat Aug 07, 2010 5:54 pm

Re: Post your SparkFun.com bugs and issues here!

Post by mattmoss » Thu Nov 18, 2010 9:27 pm

Ran into a problem where volume discounts weren't being shown.

Specifically, added 10x http://www.sparkfun.com/products/9806 ; cart showed unit price of .95, w/ 9.50 total.

I was logged out at the time; logged in w/ my account, and the unit price displayed correctly (.86 w/ 8.60 total).

Beta
Posts: 16
Joined: Fri Nov 19, 2010 2:43 pm

Re: Post your SparkFun.com bugs and issues here!

Post by Beta » Fri Nov 19, 2010 2:57 pm

I am trying to submit a comment to one of your product pages and I get these error messages:
  • Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.6; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C)
    Timestamp: Fri, 19 Nov 2010 21:46:34 UTC


    Message: 'SFE' is undefined
    Line: 315
    Char: 111
    Code: 0
    URI: http://www.sparkfun.com/products/9712


    Message: 'down(...)' is null or not an object
    Line: 603
    Char: 9
    Code: 0
    URI: http://www.sparkfun.com/js/sparkfun.js
This prevents me from submitting comments to this products page. However, since I have noticed this error, others have been able to post comments. I am assuming that this affects other product pages as well. I am using IE 8.0.

pzerkel
Posts: 1
Joined: Fri Nov 19, 2010 2:56 pm

Re: Post your SparkFun.com bugs and issues here!

Post by pzerkel » Fri Nov 19, 2010 3:11 pm

On the Port-a-Rotary project page,

"We've finished the ringer circuit! View it here." clicking the link takes me to your "Woah there Turbo!" page.

Beta
Posts: 16
Joined: Fri Nov 19, 2010 2:43 pm

Re: Post your SparkFun.com bugs and issues here!

Post by Beta » Mon Nov 22, 2010 5:50 am

Beta wrote:I am trying to submit a comment to one of your product pages and I get these error messages:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.6; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C)
Timestamp: Fri, 19 Nov 2010 21:46:34 UTC

Message: 'SFE' is undefined
Line: 315
Char: 111
Code: 0
URI: http://www.sparkfun.com/products/9712

Message: 'down(...)' is null or not an object
Line: 603
Char: 9
Code: 0
URI: http://www.sparkfun.com/js/sparkfun.js

This prevents me from submitting comments to this products page. However, since I have noticed this error, others have been able to post comments. I am assuming that this affects other product pages as well. I am using IE 8.0.
I just ran your site in compatability mode and it worked fine. Could you possibly fix it to work with newer browsers like IE 8.0in compatability mode and it worked fine. Could you possibly fix it to work with newer browsers like IE 8.0

stilldavid
Posts: 14
Joined: Tue Sep 11, 2007 1:26 pm
Contact:

Re: Post your SparkFun.com bugs and issues here!

Post by stilldavid » Mon Nov 22, 2010 11:46 am

Beta wrote:
Beta wrote:I am trying to submit a comment to one of your product pages and I get these error messages:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.6; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C)
Timestamp: Fri, 19 Nov 2010 21:46:34 UTC

Message: 'SFE' is undefined
Line: 315
Char: 111
Code: 0
URI: http://www.sparkfun.com/products/9712

Message: 'down(...)' is null or not an object
Line: 603
Char: 9
Code: 0
URI: http://www.sparkfun.com/js/sparkfun.js

This prevents me from submitting comments to this products page. However, since I have noticed this error, others have been able to post comments. I am assuming that this affects other product pages as well. I am using IE 8.0.
I just ran your site in compatability mode and it worked fine. Could you possibly fix it to work with newer browsers like IE 8.0in compatability mode and it worked fine. Could you possibly fix it to work with newer browsers like IE 8.0
This is an ongoing cat-and-mouse game while we continue to push out bug fixes - fix it for IE7, it breaks in safari on windows. Push for IE8 it breaks for chrome on mac... you know how it goes :)

I just pushed a change that should fix a lot of IE8 javascript issues - let me know if it is still broken.

For the record, we're targeting IE7+

stilldavid
Posts: 14
Joined: Tue Sep 11, 2007 1:26 pm
Contact:

Re: Post your SparkFun.com bugs and issues here!

Post by stilldavid » Mon Nov 22, 2010 11:49 am

pzerkel wrote:On the Port-a-Rotary project page,

"We've finished the ringer circuit! View it here." clicking the link takes me to your "Woah there Turbo!" page.
Updated those two links, thanks for the heads up!

Luka
Posts: 2
Joined: Mon Nov 22, 2010 1:35 pm

Re: Post your SparkFun.com bugs and issues here!

Post by Luka » Mon Nov 22, 2010 2:04 pm

Every time I select an address (I have two) and get my shipping calculated in my cart, all the prices of the stuff in my cart drop. Repeating that I managed to get everything in the cart (and the cart total) to €0.01, though it won't go below that.

Beta
Posts: 16
Joined: Fri Nov 19, 2010 2:43 pm

Re: Post your SparkFun.com bugs and issues here!

Post by Beta » Mon Nov 22, 2010 2:23 pm

stilldavid wrote:I just pushed a change that should fix a lot of IE8 javascript issues - let me know if it is still broken.
It still is broken, with similar error messages on different lines.

It's not that improtant to me if it works without having compatability mode on, because all I have to do is click a button and it works. Other people that aren't familiar with using compatability mode are the people that would need this fix. And with IE 9.0 on its beta release, your probably going to need to update it soon to work with the newer browsers anyway.

SadE
Posts: 12
Joined: Fri May 16, 2008 10:54 am

Re: Post your SparkFun.com bugs and issues here!

Post by SadE » Tue Nov 23, 2010 5:55 am

I'm trying to place an order , but I cannot checkout my cart :
When I choose an address , and press 'calculate shipping' , it loops for several minutes (with the two circle array on the web page moving).
After that the address is displayed in grey , but no shipping fees are displayed and If I pressed 'check out' , nothing happens. :(
I'm using Firefox 3.6 on win xp sp2.

Edit: after some several tries , I got a new page telling me that there's something wrong with the sipping quotes. It advices me to check my postal address (that never changed :)

Edit 2 : it's working now. Thnaks ;-)

Salomon926
Posts: 1
Joined: Wed Nov 24, 2010 10:02 am

Re: Post your SparkFun.com bugs and issues here!

Post by Salomon926 » Wed Nov 24, 2010 10:04 am

I noticed on the news page:
http://www.sparkfun.com/news
that the current post (the free day post) is out of order.

Post Reply