SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Imaging category should be posted in this forum.
User avatar
By S_Jafri

We recently received two of the IR Array Breakout Boards (V12) but we have run into the same error regarding EEPROM Parameter. Currently we are using these boards with the Melexis Evaluation board and using their software to get the imaging. We do have a breakout board (V10) we purchased previously that works with the Evaluation board with no issues. I've attached screenshots of the error as well as a picture of our setup (Note: we are currently using the QWICC connection for this setup, the soldered wires just lead out to an unplugged connector that would be used to connect to the Melexis Evaluation board). Is there anything we can do to resolve these EEPROM errors we are getting on the new boards?
You do not have the required permissions to view the files attached to this post.
User avatar
By TS-Mark
Hi S_Jafri,

Unfortunately, we cannot help you out too much with this issue since we do not carry the Melexis Evaluation Board so it is impossible for us to try and recreate your issue. Since it is working with the previous revision of the board, the issue is most likely with the MLX90640 breakouts but without testing on in an Arduino environment like our Hookup Guide covers, I am not sure what the issue might be. If possible, try testing the sensors with our Arduino library or at least run an I2C scan to see if the bus can detect the MLX90640.

We found with other users that testing the SDA and SCL lines for resistance/continuity to ground helps identify a defect. If you have a multimeter, try measuring resistance and testing for continuity with GND while the sensor is unpowered.
User avatar
By S_Jafri
Hi TS-Mark,

So we've tried setting up the MLx90640 breakout boards using the Arduino hookup guide you linked and a Teensy 3.5 as the microcontroller. We had no issue using the V10 board but when we used the V12 boards the following is shown:

"MLX90640 IR Array Example
MLX90640 online!
Parameter extraction failed
Pixel 0: nanC
Pixel 1: nanC
Pixel 2: nanC
Pixel 3: nanC
Pixel 4: nanC
Pixel 5: nanC
Pixel 6: nanC
Pixel 7: nanC
Pixel 8: nanC
Pixel 9: nanC"

We also used the I2C Scanner you mentioned on got the following message:
"I2C Scanner
I2C device found at address 0x33 !

We did find that if we start the programs with the V10 board and swap to one of the V12 boards we were able to get readings, however this wouldn't be ideal for our application. Do you have any suggestions on how we can further troubleshoot these boards?