SparkFun Forums 

Where electronics enthusiasts find answers.

By BerndNW18
I recently bought 2 pc of Sparkfun's nRF52832 Breakouts. I followed their tutorial ( ... okup-guide) step-by-step. I was able to program the board with the first example, so the LED does flash. (Having no problems with the press-and-release-reset-and-user-buttons sequence)

However, when I flash the second example and try to connect my phone via the nRF Connect app, the device doesn't appear in the list (only other devices show, which are for sure not the nRF52832). This is true for both of my brand-new boards!

I already tried a slightly different example, to no avail:

I also tried powering the board externally, to rule out the possibility that my FT232 might not be able to source enough current over it's internal voltage-regulator.

This really startles me, any ideas anybody? Anybody have a working example at hand, maybe alternatively one using KEIL? I could even get a grab on a J-Link (or U-Link, for that matter) if I had to.

My Setup:
Win10 64Bit
aforementioned nRF52832 Breakout (genuine Sparkfun)
FT232RL-Breakout as USB2Serial Converter
external 3.3 V power supply to the breadboard I'm using (measured and verified good)
Arduino IDE 1.8.5

Thanks :)