Page 1 of 1

Sparkfun open PIR not working

Posted: Sat Jan 05, 2019 12:43 am
by andrewswinburne
I just received a new sparkfun openpir (SEN-13968) and it seems like its not working. The Green LED stays on full time no flashing. Am I doing anything wrong? I am using a regulated 5V supply also tried 3.3V its still the same. The xLED jumper is obviosly connected to GND with solder. Also... when the 'OUT' pin is on high (not the Analogue out) what is the voltage expected there?

Re: Sparkfun open PIR not working

Posted: Mon Mar 11, 2019 10:49 am
by TS-John
Have you tried adjusting the trim-pots by chance? I think having either or both set t to maximum or minimum may cause strange effects.

I believe the voltage on the pin should output what you are supplying the device. If using a 5v supply, the output pin should be 5v.

Re: Sparkfun open PIR not working

Posted: Wed Aug 14, 2019 1:37 pm
I had a similar power issue that might be solved with either of the two pots. I'm throwing this out here for general conversation and confirmation.

I connected my OpenPIR to a Particle board (Argon) that was being powered via my PC's USB port. I connected the OpenPIR's Vcc to the Particle's "USB" output. From what I understand, this is an unregulated line coming directly from the USB cable connected to my PC. When I plugged in the PIR, Vcc dropped from 5.1v all the way down to 1.5V - with NO green LED on the OpenPIR. We suspected the PC uses a large cap to prevent sudden surge loads, so we placed a 330 ohm resistor (5v/330 = 15mA) in series with the OpenPIR's Vcc to slow that initial surge. The voltage bounced around between 4.1V and 4.7V, but at least the OpenPIR appeared to be powered on and stable. I next tried connecting Vcc to a regulated 3.3V output (also on the Particle board). The OpenPIR powered up without an issue and the voltage remained steady. From the OpenPIR schematic I can see the RC network and see it is connected to Vcc. My guess is that a large external cap (such as on the output of the PC's USB port) would wreck havoc on the OpenPIR's RC network...?