SparkFun Forums 

Where electronics enthusiasts find answers.

Have questions about a SparkFun product or board? This is the place to be.
By fabian_sl
I've been working great with my RELAYplate and DAQCplates connected through jumper wires with solid tips to my Raspberry Pi 3. Last week I wanted to connect my Raspberry Pi 3 to a 7" touchscreen (like this one: ... h-display/) with both RELAY and DAQCplates as hats on top of the Rpi, and a GPIO ribbon cable on top of them to use the free GPIOs, and the screen turned on and everything was ok, until I executed my program and received some errors stating that the plates couldn't be found at address 0 (that's the address I configured on them and that have been working with). I've been testing my rpi and all gpios are working correctly (I even did an SPI loop test suggested and it worked as expected). Now I'm testing each plate by itself and this is what I get (same result on RELAYplate):

pi@raspberrypi:~/Generador/gui_10_17_18 $ python3
Python 3.5.3 (default, Jan 19 2017, 14:11:04)
[GCC 6.3.0 20170124] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import piplates.DAQCplate as DAQC
>>> DAQC.getID(0)
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/local/lib/python3.5/dist-packages/piplates/", line 333, in getID
File "/usr/local/lib/python3.5/dist-packages/piplates/", line 388, in VerifyADDR
assert (daqcsPresent[addr]==1),"No DAQCplate found at address "+addr_str
AssertionError: No DAQCplate found at address 0

I've tried changing the address with the DAQCplate's jumpers and changing DAQC.getID(x) to the address set and the result is the same. Is there any test I could do to my DAQCplate and RELAYplate to know what could be wrong? I'm pretty sure the connections were ok, and power leds are turning on on both plates.
User avatar
By Santa_Impersonator
This might be a better question for pi-plates (the manufacturer):

However, as listed on their FAQ (, they use the SPI interface, which I think the 7" display also uses... that might be the issue. If I remember correctly (and I could be wrong), all the touch displays use SPI and usually aren't compatible with other SPI devices.