Large 7 segment displays flickering

Have questions about a SparkFun product or board? This is the place to be.

Moderators: phalanx, TS-Tim

Post Reply
wingslike
Posts: 1
Joined: Thu Oct 19, 2017 11:47 am

Large 7 segment displays flickering

Post by wingslike » Thu Oct 19, 2017 1:59 pm

Hi all,
I am building a counter with twelve large 7 segment displays (COM-08530) and the large digit drivers (WIG-13279). I am running them with an Arduino and have all twelve digits in a single data chain. The display works fairly well but I have an intermittent problem where the last 2-5 digits flicker after 20 minutes. What I mean by flicker is that the display segments alternate on and off, displaying nonsense. I have tried moving the digits so that digits are not always in the same position in the chain and yet the symptoms remain similar. I assume moving digits rules out a defective connection or driver. I am looking for suggestions to solve the issue.

I have considered that it is not ideal to have all twelve digits in a single chain. Perhaps the signal gets degraded by the end of the chain. However, I am not seeing noise in the data at the end of the chain using an oscilloscope. I tried connecting +5v and ground to both ends of the display to minimize voltage drop through the chain.

I am contemplating connecting +5v, +12v, Ground, Latch, and Clock to both ends of the chain. Does anyone see any issues with trying this? Obviously I cannot do this with the Data. I am also considering breaking the data chain into two or more groups.

Any suggestions would be appreciated. Thanks!

Post Reply