SparkFun Forums 

Where electronics enthusiasts find answers.

Have questions about a SparkFun product or board? This is the place to be.
By mattmunee
#180114
I know this post is a bit old, but I wanted to post on my status. I ran into the exact same problem. After reading this forum, I had a similar problem. I was using an 3.3V FTDI adapter from LowPowerLab that has worked interchangeably with a similar Sparkfun adapter on other projects. However, in this case, it did not. I was using an Arduino Pro Mini 3.3V microcontroller. Switching to the Sparkfun FTDI adapter fixed the problem. Be careful with your level shifting!
By Sergey Vasilenko
#188011
Hello!
I had same problem with lsm9dso, but it is appear sometimes after some resets. Sometimes all was good. At first was blocked A, after M, after changed the settings. In finally, In debug mode, i read 3 status registers and see 0x88, 0xff, 0xff for M,A and G respectively, and later I noticed that CTRL_REG7_XM register is set to power down mode, and sometimes CTRL_REG1_XM register is set to disable X,Y,Z -axis of accelerometer. My solution of this problem is check this registers in beginning GetData - function and set them in correct state if it is not.
Reasons of"self-modification" of these registers are not known to me.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]