Page 1 of 1

My 5 V regulator only puts out 2 V...

Posted: Sat Apr 10, 2010 9:09 pm
by Yes0
I've got a 5 V regulator on a breadboard, using a ~15 V wall wart as the input. The problem is it only puts out 2.07 V. Other 5 V regulators have the same problem, and they work fine in other boards. Does anyone know what the problem might be?

Thanks!

Re: My 5 V regulator only puts out 2 V...

Posted: Sat Apr 10, 2010 9:16 pm
by riden
Some regulators require capacitors on the input and output sides. What regulator are you using? BTW, if you are using a linear regulator, you may be dissipating a lot of heat due to the 15v to 5v difference.

Re: My 5 V regulator only puts out 2 V...

Posted: Sat Apr 10, 2010 9:20 pm
by Yes0
It's just a standard L7805. I do have a 100 uF cap on the input and 10 uF on the output, is that not enough?

I have a heatsink on the regulator too, so the heat isn't much of an issue.

Re: My 5 V regulator only puts out 2 V...

Posted: Sat Apr 10, 2010 9:52 pm
by markaren1
Are you sure it's a DC power brick ?

Re: My 5 V regulator only puts out 2 V...

Posted: Sun Apr 11, 2010 12:02 am
by leon_heller
It might be oscillating. You should have a 0.33 uF ceramic on the input and a 0.1 uF ceramic on the output, as close as possible to the leads. See the data sheet.

15V input is too high without a heatsink, unless the load is very small.

Re: My 5 V regulator only puts out 2 V...

Posted: Sun Apr 11, 2010 7:26 am
by Yes0
The wall wart has worked before.

Leon, like I said I do have a heatsink on the regulator. Does it have to be an exactly .33 uF capacitor on the input? I don't have any of those would three .1 uF capacitors be enough?

Thank you all very much!

e: Replacing the 100 uF and 10 uF caps with three .1 uF caps on the input and one on the output didn't change anything, except now it reads 2.15 V. I don't think the caps caused the voltage to go up though, earlier last night it was only 1.99 so it seems to be gradually going up.

Re: My 5 V regulator only puts out 2 V...

Posted: Sun Apr 11, 2010 8:34 am
by leon_heller
The 0.33 uF on the input isn't very critical. I keep several on hand in case I need them, though.

I don't trust those solderless breadboards, and never use them. Try a piece of stripboard instead. I make my own PCBs and don't usually have any problems with things not working.

Re: My 5 V regulator only puts out 2 V...

Posted: Sun Apr 11, 2010 10:12 am
by sylvie369
Yes0 wrote:caps with three .1 uF caps on the input and one on the output didn't change anything, except now it reads 2.15 V. I don't think the caps caused the voltage to go up though, earlier last night it was only 1.99 so it seems to be gradually going up.
You should be good to go on April 30th, then. Are you on a deadline, or something? :wink:

Re: My 5 V regulator only puts out 2 V...

Posted: Sun Apr 11, 2010 11:40 am
by waltr
Double check to pin-out of the regulator. The data sheets usually show the pin-out from the bottom view but may show from the top. Very confusing some times. Any guesses as to how I know this?

Re: My 5 V regulator only puts out 2 V...

Posted: Sun Apr 11, 2010 11:41 am
by waltr
Double check to pin-out of the regulator. The data sheets usually show the pin-out from the bottom view but may show from the top. Very confusing some times. Any guesses as to how I learned this?

Re: My 5 V regulator only puts out 2 V...

Posted: Sun Apr 11, 2010 11:50 am
by markaren1
Sounds like its time to throw out the assumptions and re-test things in isolation.

try the 15v wall wart feeding just a 1k resistor. What is the voltage ?

can you try a 9V battery in and no load on the output of the 7805. What is the DC voltage ? Put your meter on AC and confirm 0V AC also (might be able to see if there is instability).

how about a close in photo of the wiring ?

This photo is how I usually hand wire a 7805. Leon is strictly correct with his values, but I have never had any stability issues using 2 x 100nF caps wired close in. The photos uses 2 x 100nF 0805 X7R ceramics.

-Mark
7805 caos.jpg
7805 caos.jpg (10.82 KiB) Viewed 1236 times

Re: My 5 V regulator only puts out 2 V...

Posted: Sun Apr 11, 2010 5:01 pm
by Blackfin
Yes0 wrote:I've got a 5 V regulator on a breadboard, using a ~15 V wall wart as the input. The problem is it only puts out 2.07 V. Other 5 V regulators have the same problem, and they work fine in other boards. Does anyone know what the problem might be?

Thanks!
If the output of the regulator section is low -- 2V -- and the problem is occurring with other regulators that are working fine in other boards then that suggests the board is the problem. Does the regulator get warm? Is there an excessive current draw that's pulling the output voltage low? What's the input voltage when the regulator is at 2V output?