SparkFun Forums 

Where electronics enthusiasts find answers.

Have questions about a SparkFun product or board? This is the place to be.
By Lmdriver
#108727
hi kushan,
thanks for the advice of using Test Application.
I have used that but i am not understanding the correct procedure like what we have to do after each step.
I opened the device and set the baudrate using OpenDevice and BaudRate respectively.
after that i used the GetImage and UpImage, and also enabled Display.
I thought that i may be getting the fingerprint on the space provided for it but it didnt came.

so now I want the procedure (or steps) to be followed so that i can do it correctly and expect for the correct output.

I have another question like why the readme text is not given. it may help(easy) the work for the person working on that module.
it is the advice from me to the test application makers.

if some can tl me the steps to be followed and if possible send to the message box.

thanks & regards
Lmdriver
By dbrownjr
#109064
Hello everyone,

I know its been a while,but I do have more information on the scanner after talking repeatedly to the Aratek.
This information was just received and is regarding how the program is designed/ written in regard to the demo as well as the operation of the scanner's functions.
The compressed folder is to big to upload and it has an exe ( can't be sent through gmail). Please email me at my yahoo account if you want this file. Ultimately, I want to connect this to a microcontroller. On step closer!


Best,

Delester
phileator@yahoo.com
By prosenbe
#111250
I am currently using this fingerprint scanner for a project at school interfacing with an Arduino Atmega328 and so far this forum has been immensely helpful.
However, I have come to a problem when I run my enrollment code.
I am receiving acknowledgement responses for the get_image, store_char1, and store_char2 commands that I send.

When I send the create_template command:
Command: (0xEF, 0x01, 0xFF, 0xFF, 0xFF, 0xFF, 0x01, 0x00, 0x03, 0x05, 0x00, 0x09)
Response: (0xEF, 0x01, 0xFF, 0xFF, 0xFF, 0xFF, 0x07, 0x00, 0x03, 0x0A, 0x00, 0x14)

I did not expect to get 0x0A in my data packet. I expected 0x00 like I received for the rest of my commands sent before this.
Response: (0xEF, 0x01, 0xFF, 0xFF, 0xFF, 0xFF, 0x07, 0x00, 0x03, 0x00, 0x00, 0x10)

What does 0x0A mean as a confirmation code?

Also I am having trouble running a match sequence. My alogorithm looks like this:

Get Image (Fail)
Get Image (Fail)
Get Image (Success)
Store in Char 1 (Success)
for (k=0;k<idcount;k++)
{
load id k into char 2
match char 1 and char 2
if (success) -> record id
if (fail) -> continue looping
}

I do not know if I am doing this right because as of now I am having trouble storing the fingerprints.
I get a similar response every time:
Response (0xEF, 0x01, 0xFF, 0xFF, 0xFF, 0xFF, 0x07, 0x00, 0x05, 0x08, 0x00, (random number under 64), 0x00, (correct checksum value))
Again I don't know what 0x08 means as a confirmation code, but I assume the next 2 bytes are an address of some sort?
I also noticed a Search function but wasn't sure how to use that.

I know this forum has been dead for awhile, but any response would be helpful.

Paul
By brad09
#118378
Hey, I am thinking of purchasing this module, after looking through the forums, I wanted to know what the best/easiest microcontroller to use. I am working on a senior design project that is involving a fingerprint sensor to be used for classroom attendance. So Involves a database, and a GUI being planned to make in matlab for students to use. Just looking for this sensors functions since I couldnt find much help from the datasheet. Thanks guys
By razvan27310424
#122557
Hi guys!

I just got one of these slide FP scanners, and I want to use it with an arduino and make a lock open.... or even just an LED light up when I slide my finger. The data sheet doesn't have much info. I have no clue how to hook it up or how to access its memory or anything. Can anybody help me with this please?

Thanks!
By homer
#126135
Hey all

I've got this fingerprint scanner and the example application. Using my own code I can easily enrol fingerprints, however I'm having difficulty getting a resoponse from the search function (0x04):

"search the fingerprint database according to the features document in the charBuffer1 or charBuffer2"

My reqest packet format is the following:

ef 01 ff ff ff ff 01 00 04 04 00 00 09

As a parameter I pass 00 to indicate the first charBuffer, the response is confirmation code 9

Is my packet format ok?
By Msantamaria
#126542
Does any one knows how to use this functions on a pic18f4520 programming on c language ? Because the datasheet tell a lot of functions but how to call this functions?
By Kushan101
#126696
hi,

calling these function means send appropriate bytes through UART Tx pin and get the response through Rx pin

as a example,

for the function PS_GetImage you have to send 0xEF, 0x01, 0xFF, 0xFF, 0xFF, 0xFF, 0x01, 0x00, 0x03, 0x01, 0x00, 0x05
and you will get the response accordingly..

difficult thing is understanding requests and response and debug this on a PIC..

reply if you need any further help..
By Priessyabsete
#126707
One more thing, depending on the age of your scanner and software you might want to check the manufacturers web site for driver or software patches. Many a scanner memory problem is fixed with newer drivers
By jamshiddastur
#135653
Thanks AJ, have worked around the Demo App and understood its work out using the serial monitor.

Just a note for those who having problem in getting the demo application work around.
1. If the Display check is on then it will take time to read and display the picture
2. Default baud rate is 57600 not 115200

Regards
JD
By inteldana
#136085
hi michelle,

i have being reading your submissions on the fingerprint slide scanner.
i'll be glad if u could send me the test software from the manufacturer.
thanks
By thatoneguydavid
#136949
Michelle L. wrote:i have completed my project based on this FP sensor. Managed to get it up and running and its pretty easy once you get the hang of the serial commands and sequence. I'm quite pleased with this sensor actually.

I have a test software from the manufacturer to communicate with the sensor. PM me your email if you want it.


Michelle.

i tried to PM you, but i was not able to figure out how to. can you please contact me to send me the dev code you came up with?
thank you,
ThatOneGuyDavid
By shanham
#137045
Hello All,

After working through this thread I was able to get the EM01Test.exe demo app to work: Enroll, Match(1:N) the whole thing. Just now I did a 'SetBaud' to 9600 as I was about to tackle interfacing the FS to an arduino Duemilove. Now the OpenDevice fails on the demo app. It just hangs. If I pull the RST pin low on the FS the the demo app 'unhangs', but it fails to connect. BTW I have a serial port logger running and it displays this when I do an OpenDevice. The answer comes back immediately but the app hangs until I reset the FS.

Request:
EF 01 FF FF FF FF 01 00 03 0F 00 13

Answer:
EF 01 FF FF FF FF 07 00 13 00 00 05 00 09 00 78 00 01 FF FF FF FF 00 C2

Any ideas what I have done and what I can do to make the demo app work again?

Thanks in advance.
  • 1
  • 5
  • 6
  • 7
  • 8
  • 9
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]