M6E-Nano power issues

All things pertaining to wireless and RF links

Moderator: phalanx

Post Reply
chief
Posts: 12
Joined: Fri May 13, 2011 2:16 am

M6E-Nano power issues

Post by chief » Tue Nov 06, 2018 1:51 am

Hi, first of all i didnt find the answer im looking for, hens the new topic :)

So the issue im having is as follows.
i have M6E nano simultaneous reader connected to arduino (later im connecting it to raspi but thats when i get it with poe shield)
there is continuous reading program on arduino and it reads pretty well on 5dbm power.
when i connect it to external power (lab bench power supply to arduino 12V 4A) it works well and reads the tags.
but than i crank up the power to 25 or 27 (which is the power i need actually) it just restarts every time.
if i connect the usb to computer too than up to 20dbm it works, but the further i go the worse the results.

i have tried connecting it to external usb power - 2A powerbank
Lab bench power supply
12V 4A wall adapter
even liion battery, but they died pretty fast as i dont have a huge batteries.

now i turn to you, the brains of this project with a questions -
do you know what to do?
maybe someone have had the same or similar problem?

the thing is that i need it to be 27dbm because whell 25 is a little bit too short ( in the distance)
the ideal thing would be to get it hooked up to a wall adapter, that is why i got it in the first place, but the constant reboot of the module and the arduino itself is a no go..

ok, so any ideas? thanks :)
-chief

paulvha
Posts: 303
Joined: Sat Nov 11, 2017 2:39 am

Re: M6E-Nano power issues

Post by paulvha » Tue Nov 06, 2018 6:31 am

Indeed enough power is important for the M6E reader. I always use an external lithium battery (3.7V/2000mA) next to the VCC from Arduino and connect that to the (optional) battery connection. I hardly use more than 5dbm as I don't have an external antenna connected and for testing it works good. BUT as you say.. the battery will run flat even in this setup after a while.

No matter how much voltage/power you bring to an Arduino the maximum output is determined by the Arduino on-board regulator ( ncp1117st50t3g). That is about 1A max. Depending on your USB port setup, it can provide more power directly on the USB connection to the nano.

The best way forward is to connect an strong external power source of 5V MAX directly on the board. However try to do so that this 5V does not flow back to the Arduino VCC, as that could potentially cause damage to the Arduino on-board regulator.

chief
Posts: 12
Joined: Fri May 13, 2011 2:16 am

Re: M6E-Nano power issues

Post by chief » Thu Nov 15, 2018 7:17 am

Thanks for the replay.
Here is what i did:

I connected a reliable 5V power supply directly to M6E and powered the arduino from different source
- that did not work, because arduino could not communicate with M6E
So than i connected arduino directly to 5V and basically im powering the whole system from battery inputs on the M6E board.
Everything actually works, in the future im guessing that arduino onboard regulator will fry but for the 5 minute test i needed it wrked pretty well actually, so, on to the next part - hook it up to raspberry pi and power the whole thing via PoE.
-chief

paulvha
Posts: 303
Joined: Sat Nov 11, 2017 2:39 am

Re: M6E-Nano power issues

Post by paulvha » Thu Nov 15, 2018 10:00 am

When I connect an external power source the communication works. A stupid question : did you connect RXD, TXD and GND to the Arduino ?
regards,
Paul

chief
Posts: 12
Joined: Fri May 13, 2011 2:16 am

Re: M6E-Nano power issues

Post by chief » Tue Nov 20, 2018 6:47 am

Yes i did connect them.
i think that there is some kind of weird bug on my side, because previously i didn't have this issue.
The same boards with the same code worked well via external supply and stuff. just as i went outside this happened.
-chief

Post Reply