SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
By chief
#200899
Hi, first of all i didnt find the answer im looking for, hens the new topic :)

So the issue im having is as follows.
i have M6E nano simultaneous reader connected to arduino (later im connecting it to raspi but thats when i get it with poe shield)
there is continuous reading program on arduino and it reads pretty well on 5dbm power.
when i connect it to external power (lab bench power supply to arduino 12V 4A) it works well and reads the tags.
but than i crank up the power to 25 or 27 (which is the power i need actually) it just restarts every time.
if i connect the usb to computer too than up to 20dbm it works, but the further i go the worse the results.

i have tried connecting it to external usb power - 2A powerbank
Lab bench power supply
12V 4A wall adapter
even liion battery, but they died pretty fast as i dont have a huge batteries.

now i turn to you, the brains of this project with a questions -
do you know what to do?
maybe someone have had the same or similar problem?

the thing is that i need it to be 27dbm because whell 25 is a little bit too short ( in the distance)
the ideal thing would be to get it hooked up to a wall adapter, that is why i got it in the first place, but the constant reboot of the module and the arduino itself is a no go..

ok, so any ideas? thanks :)
By paulvha
#200900
Indeed enough power is important for the M6E reader. I always use an external lithium battery (3.7V/2000mA) next to the VCC from Arduino and connect that to the (optional) battery connection. I hardly use more than 5dbm as I don't have an external antenna connected and for testing it works good. BUT as you say.. the battery will run flat even in this setup after a while.

No matter how much voltage/power you bring to an Arduino the maximum output is determined by the Arduino on-board regulator ( ncp1117st50t3g). That is about 1A max. Depending on your USB port setup, it can provide more power directly on the USB connection to the nano.

The best way forward is to connect an strong external power source of 5V MAX directly on the board. However try to do so that this 5V does not flow back to the Arduino VCC, as that could potentially cause damage to the Arduino on-board regulator.
By chief
#201002
Thanks for the replay.
Here is what i did:

I connected a reliable 5V power supply directly to M6E and powered the arduino from different source
- that did not work, because arduino could not communicate with M6E
So than i connected arduino directly to 5V and basically im powering the whole system from battery inputs on the M6E board.
Everything actually works, in the future im guessing that arduino onboard regulator will fry but for the 5 minute test i needed it wrked pretty well actually, so, on to the next part - hook it up to raspberry pi and power the whole thing via PoE.
By paulvha
#201006
When I connect an external power source the communication works. A stupid question : did you connect RXD, TXD and GND to the Arduino ?
regards,
Paul
By chief
#201075
Yes i did connect them.
i think that there is some kind of weird bug on my side, because previously i didn't have this issue.
The same boards with the same code worked well via external supply and stuff. just as i went outside this happened.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]