ESP8266 serial AT in Korean

All things pertaining to wireless and RF links

Moderator: phalanx

Post Reply
hsieber
Posts: 2
Joined: Sun Aug 12, 2018 9:10 am

ESP8266 serial AT in Korean

Post by hsieber » Sun Aug 12, 2018 9:31 am

Hi, new member. I am trying to integrate the ESP8266 (WRL-13678) into an existing embedded logging product so as to add WIFI. If possible I would prefer to use AT commands via the ttl serial interface, and use the module 'off the shelf' without any programming. When I hook up the unit I have via a ttl-to-rs232 module, connect it to a pc-based terminal emulator, and power up, all of the text appears to be in Korean alphabet. Looks like a sign-on with some text, and then it does respond to serial input (AT<CR><LF>), but only in Korean. So is there a way to coerce it into English, or do I need to bite the bullet and program in the AT command set handler? Note to other new users- the RESET line has no pullup, must be tied high to operate!

paulvha
Posts: 289
Joined: Sat Nov 11, 2017 2:39 am

Re: ESP8266 serial AT in Korean

Post by paulvha » Mon Aug 13, 2018 9:29 am

Might the "Korean" be the fact that you have the wrong baudrate on terminal emulator? E.g. 115200 instead of 9600 or the other way around ? or maybe you do not have 8bit, 1 stop and NO parity?

hsieber
Posts: 2
Joined: Sun Aug 12, 2018 9:10 am

Re: ESP8266 serial AT in Korean

Post by hsieber » Mon Aug 13, 2018 9:42 am

Apologies, please disregard previous post. This turned out to be a terminal emulator problem. We can add TeraTerm to the terminal emulators that do not work well with 8266. Hyperterm works fine. AT commands seem to work as specified (so far). I am new to WiFi, not sure if I can actually transmit data using only AT commands, more reading and experimentation to do. I have looked at Neil Kolban's excellent e-book, but like almost all of the tutorials and articles, it seems to focus on how to re-flash the module with your own code, which I am trying to avoid if possible.

Thanks paulvha for the suggestion, but the characters were not garbled as you would see with wrong line settings, but actual Korean characters, which I didn't even know were in my PCs fonts. Weird that TeraTerm would display in Korean, never have seen that before.

Post Reply