M6E-Nano Help Updating Firmware

All things pertaining to wireless and RF links

Moderator: phalanx

Post Reply
aldonair92
Posts: 6
Joined: Thu Nov 16, 2017 5:30 am

M6E-Nano Help Updating Firmware

Post by aldonair92 » Tue Mar 06, 2018 10:29 am

Hi guys,

I bought M6E-Nano board with the USB-serial attachment and some UHF tags.

Following the guide at sparkfun, im trying to simply read the tags. I've been trying to use the URA (Universal Reader Assistant) for this, but so far its not working. The URA checks my card, but when setting it to "Read", it does not catch any tag.

I've checked the dbm power below 5dbm (using usb-serial), but right now my concern is the firmware version.
According to URA, only M6E with firmware v1.19.0 and later can be used and Nano firmware must be v1.5.0 and later.

First, I dont understand which firmware should I update? The M6E? or the Nano? I cant seem to find any M6E-Nano firmware on Thingmagic...
Second, when trying to update the firmware thorugh the URA, using the M6E 1.21 update it gives me the following error: "a flash command can not access multiple sectors". Using the Nano 1.7 update, it gives me a "Succesful" message, but the firmware its still the same...

This is my actual conf according to URA:
- Firmware Version : 1.07.03.17
- Hardware Version : 30.00.00.02
- URA Version : 3.4.34.34
- Mercury API Version : 1.29.4.34

Can anyone help me with this? Any tips?

Many thanks in advance!

paulvha
Posts: 289
Joined: Sat Nov 11, 2017 2:39 am

Re: M6E-Nano Help Updating Firmware

Post by paulvha » Tue Mar 06, 2018 1:17 pm

I have an M6E nano and have been using this so time now and It alls works. When I started I did not know where to hold the tag. So during test I now just put the M6E-Nano board on top of the tag (3/4 to the end near the antenna) on the table and it then reads. You have to select 1 antenna, the local region and indeed set for low dbm power in "performance tuning" drop down ( I use 4 when no external source is connected) for both read and transmit in the menu. My firmware is 1.07.02.12 (time to update :-). There is NO 1.9 for the Nano (look at http://www.thingmagic.com/manuals-firmware#Nano) you seem to have the latest, but even then it should work.
edit: I have just updated to 1.07.03.17. I had to reinstall the URA from the web (restart did not work) My URA version is now 3.4.34.34 and it reads the tag.

regards,
Paul

aldonair92
Posts: 6
Joined: Thu Nov 16, 2017 5:30 am

Re: M6E-Nano Help Updating Firmware

Post by aldonair92 » Wed Mar 07, 2018 1:20 am

thanks for the reply.

I will try again soon. By the way, any kind of tip regarding "baud rate"?

Many thanks!

paulvha
Posts: 289
Joined: Sat Nov 11, 2017 2:39 am

Re: M6E-Nano Help Updating Firmware

Post by paulvha » Thu Mar 08, 2018 3:06 am

I have connected with a USB port, but according to the datasheet: Upon initial power up, the default baud rate of 115200

Post Reply