SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
By mchahn
#187593
I have an xbee network with a usb coordinator (api) and four routers (at). It has worked for over a year. I was trying to add a ge link light bulb so I was changing the coordinator parameters almost randomly. It previously had all default params except for a pan id and channel mask set to channel 11 only.

Discovery quit working at various times for obvious reasons. At one point I set it back to my old settings and discovery didn't work. The usb access to the chip did everything fine except discovery. I tried everything. I restored firmware, did a recovery, etc. I assumed my radio in the chip died.

I put in a xbee chip from one of my routers and verified the network settings matched the coordinator. I then flashed the coordinator firmware onto that chip with the same settings. Nothing changed with the new chip.

So I know the chip is good, and my usb connection is good, but discovery doesn't work with any of the old routers that I haven't touched. The only thing left that could be bad on the explorer is the board itself which makes no sense.

Does anyone have any ideas what could kill discovery? I'll try anything.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]