SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
By sakibnaz
#186829
Hi All.

I am problem in my project with Telit Module to activate the GPRS from MCU UART.

I know the EasyGPRS AT Commands to Activate GPRS and send UDP Data. The strange issue is ... when I an sending the AT Command manually by typing from PC Hyper-Terminal then all works. Module can send UDP Data to Server. But when I am sending exact same AT Commands from MCU UART then Module reply ERROR against AT#SGACT=1,1,"","". But other AT Command reply is OK.

Below are my Command which I tried with Module Response (with Echo ON):

AT
OK

AT+CMEE=2
OK

AT&K0
OK

AT+CGDCONT=1,"IP","internet","0.0.0.0",0,0
OK

AT#SGACT=1,1,"",""
+CME ERROR: activation failed


AT#SD=1,1,"31000","110.50.103.97",0,0
+CME ERROR: operation not supported

HELLO


I tried the regular GPRS AT Command as well. Then same ERROR comes with AT#GPRS=1 Command.

Note: The problem only happens when I can sending the Command from MCU. Exact same Command working fine when sending from PC Hyper-Terminal ... :(

Anyone can advise whats the issue?

Thanks in advance.

Regards.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]