SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
By mth
#148497
Has anyone tried the new S3B version (Part no. XBP9B-XC...) of the Pro XSC ? It has extended range, less current draw, but otherwise is supposed to be pin and RF compatible with the older model that Sparkfun is still selling (XBP09-XC...).

Anyway, I purchased one from Digi and dropped it in, in place of the older model of which I have two. It kinda works. I can Test/ Query it in X-CTU with the module connected via Sparkfun XBEE Exploreer USB, and get an OK. But under the modem configuration tab, I am unable to read parameters. When I try to read parameters I get communication errors and it says modem config file not found and other stuff. I Downloaded version updates to X-CTU and still have the same problem. Also, on the X-CTU terminal window I am recieving an incrementing 8 character word scrolling up the screen, when I am not expecting to receive any data at all.

I can send data back and forth between the older model connected to the Explorer USB and the S3B conected to a SF XBEE Regulated Explorer over the air, but data is sporadic and only partially coming through.

Does anyone have one working communicating with SF XBEE Explorers and the older model?
By mth
#148596
I emailed Digi, and their Tech support answered my question, see below. This explains my symptoms pretty clearly (incrementing, or sequential numbers being generated from radio). Hopefully SparkFun deigns a new XBEE Explorer board when they start selling the Pro XSC S3B. Also not mentioned here, but the S3B D I/O lines are not 5 V tolerant like the old model.

------
Mark,

If you connect an XBee S3B module into a third-party interface board (such as the Sparkfun USB Explorer, or Parallax USB Adapter) you will be unable to communicate to the module using X-CTU. If you view the UART of the radio, you will notice a sequential series of numbers being generated. This is because several third-party interface boards have an LED connected to pin 6 of the XBee header. This LED provides an indicator for the RSSI (signal strength) for most XBees.

The XSC (S3B) and XSC (S3) modules have a slightly different pinout than the rest of the XBee product line. Pin 6 is used as a config line rather than an RSSI indicator. A legacy feature on the S3B is a diagnostic tool called "pitch mode", when the config line is pulled low during startup, it starts sequentially counting numbers and outputs it to the UART. This feature was originally used to perform a range test allows further backwards compatibility with the XStream radio.

Because an LED indicator is connected to this config line, the S3B module will enter pitch mode due to the pin being pulled low. There is no way to bypass this mode on the XBee itself. The best solution is to remove the current limiting resistor or LED on the interface board that is tied to pin 6, which will leave the pin unused. Please refer to the manufacturer's schematic of the interface board to locate these components.

The older XSC (S3) module should not be affected by this problem because it has a higher value internal pull-up resistor on that pin. One of the advantages of the XSC (S3B) versus the XSC (S3) is reduced current draw when the module is sleeping. In order to achieve the lowest sleep current possible, the pull-up resistors used are higher in value and cannot overcome the LED pulling the pin low.

Sincerely,

Digi Technical Support
By jgtech
#149033
I can confirm, I just pulled off the resistor in line with the RSSI LED and then tested in X-CTU again. Now it sees my XBee and its configuration just fine. Thanks for posting this help!
By Balrog30
#152727
I experienced the same problem, and this also fixed it. And all I can say is thank goodness it worked, as I accidentally pulled one of the pads off the board in the process, so there is no putting that resistor back.

Thanks for the tip, saved me a lot of troubleshooting.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]