SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
By cyrus23
#119416
Hi,

i have developed my own board with the wifly rn131-g module and have some problems to bring the module into service.

the module is connected via the uart with an ARM7 LPC2388 Microcontroller. after reading the user manual i send these three chars "$$$" an the module gave me this message back:

Auto-Assoc roving1 chan=0 mode=NONE FAILED<CR><LF>*RE

now the manual says the module should give this back : "CMD" to enter command mode and configure the module. then i tried to put the PIO[9] Pin on High with the 4 DIL switcher. after turning on the power supply and debugging again the module now sends me CMD back, but still some problems remain. when i try the "show net" or "scan" order i dont get valid messages back e.g. "show net" i only get "SSID=" and after that 0xFFFF. and "scan" i only get "Disablen.." and then 0xFFFF over the uart.

i am using the IDE "keil uVision" and the "Keil ULINK2 Debugger"
By cyrus23
#119421
hi,

i wanted to upload 2 screenshots from my schematic and layout but i couldnt attach any files, according to the faqs i have to ask for permission, well im still waiting for a response from the moderator
User avatar
By phalanx
#119525
cyrus23 wrote:hi,

i wanted to upload 2 screenshots from my schematic and layout but i couldnt attach any files, according to the faqs i have to ask for permission, well im still waiting for a response from the moderator
You aren't allowed to upload files until your first post is approved. Since your first one was approved, you have had the ability to upload files. In addition to that, even from your first post you could have used the "IMG" BBcode tags to embed an image stored elsewhere on the internet.

-Bill
By follower
#119615
cyrus23 wrote:is it important that the head of the module (where the antenna is) is not mounted on the board?
Check out page 6 onwards in the datasheet: http://www.rovingnetworks.com/Docs/WiFly-RN-131-DS.pdf (From http://www.rovingnetworks.com/wifly-gsx.php)

These two sections seem relevant:
When integrating the WiFly module with on board chip antenna make sure the area around the chip antenna end the module protrudes at least 6mm from the mother board PCB and any metal enclosure.
The 8.5 mm area under the antenna end of the module should be keep clear of metallic components, connectors, vias, traces and other materials that can interfere with the radio signal.
--Philip;
By cyrus23
#119635
thanks, i have located the problem why i only received pieces of characters and not the whole message from the module. i tried to catch and save the received characters with an interrupt and finally im getting everything