I think I somehow messed up my PIC - 18F2553

Support for Bloader and Screamer

Moderator: phalanx

I think I somehow messed up my PIC - 18F2553

Postby yuval.shaia » Thu Sep 29, 2011 2:27 pm

I can’t switch to program mode.

I bought this card few days ago and played with it for a while, developed and run some simple c programs and it worked fine.
Ones I tried to deployed program I saw here http://www.pic18f.com/ and since then i’m unable to get into programing mode. I follow the instructions found here http://www.schmalzhaus.com/UBW/Doc/Firm ... ation.html and nothing happened, the green light keeps to be on and that’s it.
Do I really messed it up or that there is something to do with it.

Tnx,
Yuval
yuval.shaia
 
Posts: 5
Joined: Thu Sep 29, 2011 2:15 pm

Re: I think I somehow messed up my PIC - 18F2553

Postby Joeisi » Thu May 03, 2012 6:23 pm

Schematic?
Joeisi
 
Posts: 418
Joined: Thu Apr 26, 2012 6:59 pm
Location: Lima, OH

Re: I think I somehow messed up my PIC - 18F2553

Postby yuval.shaia » Fri May 04, 2012 3:23 am

I don't understand your answer
yuval.shaia
 
Posts: 5
Joined: Thu Sep 29, 2011 2:15 pm

Re: I think I somehow messed up my PIC - 18F2553

Postby Joeisi » Fri May 04, 2012 8:22 pm

Could you post something to tell us what your pins are hooked up to in your circuit?
Joeisi
 
Posts: 418
Joined: Thu Apr 26, 2012 6:59 pm
Location: Lima, OH

Re: I think I somehow messed up my PIC - 18F2553

Postby yuval.shaia » Sat May 05, 2012 11:58 am

Please see attached picture
Attachments
Photo 05-05-12 21 57 34.jpg
yuval.shaia
 
Posts: 5
Joined: Thu Sep 29, 2011 2:15 pm

Re: I think I somehow messed up my PIC - 18F2553

Postby Joeisi » Sat May 05, 2012 12:48 pm

Well... you could try pressing reset for a few seconds and then release, then follow the programming sequence.
Joeisi
 
Posts: 418
Joined: Thu Apr 26, 2012 6:59 pm
Location: Lima, OH

Re: I think I somehow messed up my PIC - 18F2553

Postby yuval.shaia » Sat May 05, 2012 1:17 pm

This is the usual procedure,
However my case is different, i can't switch to program mode no meter what i'm doing.
I think i deleted the original bootloader firmware.
yuval.shaia
 
Posts: 5
Joined: Thu Sep 29, 2011 2:15 pm

Re: I think I somehow messed up my PIC - 18F2553

Postby Joeisi » Sat May 05, 2012 6:34 pm

This is unlikely but there may have been a bad write over when you loaded your last bloader run, in which the own program has written over itself, to which, you will probably need to get a replacement or reprogram it yourself. Don't take my word for it though.
Joeisi
 
Posts: 418
Joined: Thu Apr 26, 2012 6:59 pm
Location: Lima, OH

Re: I think I somehow messed up my PIC - 18F2553

Postby yuval.shaia » Mon May 07, 2012 6:31 am

Thanks for your reply
yuval.shaia
 
Posts: 5
Joined: Thu Sep 29, 2011 2:15 pm


Return to Boot Loading

Who is online

Users browsing this forum: No registered users and 1 guest