Compiler

Support for Bloader and Screamer

Moderator: phalanx

Compiler

Postby gaprice » Fri Oct 24, 2008 9:19 pm

According to several tutorials on this sit you must use #pragma origin 4 at the start of source code in order to make sure there is no overlap with bloader.

Using CCS c compiler i get this error

*** Error 7 "Controller.c" Line 15(9,15): Invalid Pre-Processor directive
*** Error 43 "Controller.c" Line 15(16,17): Expecting a declaration
2 Errors, 0 Warnings.

when trying to compile this :

#include "16F877A.h" //mcu select
#pragma origin 4

void main()
{
while(1)
{
OUTPUT_HIGH(PIN_B0);
}
}

what is going on here?
gaprice
 
Posts: 1
Joined: Fri Oct 24, 2008 9:12 pm

Postby theatrus » Thu Nov 19, 2009 12:40 am

dellsmaith, your post has nothing to do with the original topic, don't hijack threads :-).

SparkFun is also not the appropriate place for general Java questions, I would suggest StackOverflow for that. But, since I'm weak at heart, I would suggest you

a) Install the JDK (not just the JRE)
b) Make sure the JDK is in your PATH

Which should solve your basic computer issues with commands not being found.
http://www.stackfoundry.com : Open Source Hardware : BeagleBoard Expansion boards, EFM32 (Cortex-M3), AVR32 Dev Boards, and debug tools
theatrus
 
Posts: 633
Joined: Thu Oct 02, 2008 1:50 pm
Location: CA

Postby phalanx » Fri Nov 20, 2009 6:05 am

theatrus wrote:dellsmaith, your post has nothing to do with the original topic, don't hijack threads :-).


He was one of the R4i software spammers. If R4i is in the signature, it's spam!

-Bill
User avatar
phalanx
 
Posts: 1540
Joined: Sun Nov 30, 2003 8:57 am
Location: Candia, NH


Return to Boot Loading

Who is online

Users browsing this forum: No registered users and 1 guest