SparkFun Forums 

Where electronics enthusiasts find answers.

User avatar
By postiebike77
#203416
Hi All,

I've bought a red board and M6E Nano board and setup per the hookup guide using the same components.

Red Board works fine all libraries set up, and can send code to the redboard and M6E is showing power on.

I can't get the URA to connect to the board over serial port, keep getting timeout error.

Is there a trick to this, I've run out of ideas!
User avatar
By TS-Mark
#203445
Hi postibike77,

This issue is usually related to either a power or connection issue. What are you using to power the RedBoard+M6E Nano? To identify whether or not there is a connection issue, please take a few photos of the top and bottom of your Simultaneous RFID Reader and attach them to your response? Also, make sure the HW UART/SW UART switch is in the SW position. Finally, what example code from the library are you using?
User avatar
By Shacklepants
#205352
I too have this issue. I have connected the sparkfun simultaneous rfid tag reader to an FTDI TTL-232R 5V ttl to usb serial converter. The switch is set to SW-UART ( though I get the same error when set to HW-UART). When I run the URA I get the following error:
"Unable to connect to USB Serial Port (COM20). Please Check if the device is properly connected or Device might be in use."

I have ensured that 5V is being supplied to the board, and that the connections to the FTDI Chip are correctly made. Looking at the serial port connections on the SRTR to the left the connections from my cable are as follows:
Green wire
Yellow wire
Orange wire
Red wire
Brown wire
Black wire.
By paulvha
#205360
Some thoughts :

Check in the devicemanager that you have the right driver loaded for the ftdi.

I assume you do NOT have the SRTR on top of an Arduino/Redboard and that you did not connect anything to enable and leave that as-is.

Although normally this should work, you could try to exchange the Yellow (rxd) and Orange (txd) from place and see what happens.

Is the power led on no the board ?
By n1ist
#205362
Check to make sure the FTDI is working:
- Disconnect it from the reader board
- Connect yellow to orange on the FTDI
- Open your com port using a terminal program (PUTTY, TeraTerm, etc).
- Type some characters and ensure that they are showing up on the screen (one per keypress if you have local echo disabled, twice if enabled in the terminal program)

If this doesn't work, the issue is on with the PC, FTDI driver, or FTDI cable.
/mike
User avatar
By Shacklepants
#205377
Hi Paul and Mike

The correct drivers are installed for the FTDI chip. I checked this in bot the device manager and by successfully performing the check that Mike suggested.
The SRTR is NOT connected to an Arduino and you are correct nothing is connected to enable . The power light is on and I have since tried using a bench supply in place of USB power, but I get the same problem.

I have tried switching yellow and orange, still the same issue.
When I initially start up the URA I'm presented with the Connection wizard which provides the Error "Unable to connect to USB Serial Port (COM20). Please Check if the device is properly connected or Device might be in use." when I click next.
If I skip the connection wizard and attempt to connect as per the sparkfun guide the error message changes to "Error connecting to reader: Timeout Exception"
I may now try an older release of the URA.

Chris
User avatar
By Shacklepants
#205409
As an Update to this I have now tried an older release of the URA and still no joy. I have also tried a different USB to serial cable which gave the same problems, as well as trying the same tests on a different USB port, and then a different Host PC all to no luck. I am completely stumped as to what to do next. If anyone has had this problem before advice is greatly received.
User avatar
By TS-Mark
#205420
Hi Chris,

It may be a hardware issue. Can you please take a few photos of the top and bottom of the Simultaneous RFID Reader and attach them to your reply? Especially any soldering you have done.
User avatar
By Shacklepants
#205422
There's not much soldering done but please see attached. I have only added a socket header into which I plug my FTDI lead.
Cheers,
Chris
You do not have the required permissions to view the files attached to this post.
By paulvha
#205443
During connect that URA tries to connect to M6E with different speeds. If it fails after trying 8 or 9 different speeds you will get this error message. I expect if you make a transport log with the URA we will see the different attempts. Maybe try it and share that transport log.

I assume you are using the VCP driver and not the D2XX. did you load the latest from the version from the website ?

I only had one situation where I could NOT connect with the M6E, which was with an ESP32. As that uses 3V3, I needed a level converter. The on-board level convertor on the M6E Nano (TXB0104) did not work well with the external level convertor and I needed to make a resistor bridge to make it work.

One other thought that COULD be an issue (but unlikely as it works on the Redboard) is the M6E firmware. I would not try that change with the URA at this stage however.
User avatar
By Shacklepants
#205578
Just wanted to update this,
I have since tried using the spark fun red board and the arduino examples. Good news, these work fine. For now I will be progressing my testing using these examples rather than the URA.
What I can say is, the Nano board works, hopefully at some point I will try get round to answering why the URA software doesn't and the FTDI lead doesn't.