Page 1 of 1

Cant seem to get sparkfun nRF52840 mini to work with arduino IDE

Posted: Thu Feb 21, 2019 8:35 am
by Stoffel
Hi, this is a real headscratcher for me as ive tried everything and exhausted anything google has to offer.

In short arduino will not compile anything for the sparkfun nRF52840 mini.

When I try to compile anything I get the error :
Code: Select all
In file included from C:\Users\<myname>\AppData\Local\Arduino15\packages\adafruit\hardware\nrf52\0.9.3\cores\nRF5/Arduino.h:5:0,

                 from sketch\Blink.ino.cpp:1:

c:\users\<myname>\appdata\local\arduino15\packages\adafruit\tools\gcc-arm-none-eabi\5_2-2015q4\lib\gcc\arm-none-eabi\5.2.1\include\stdint.h:9:26: fatal error: stdint.h: No such file or directory

compilation terminated.

exit status 1
Error compiling for board SparkFun Pro nRF52840 Mini.
Ive made an effort to follow the setup guide. By installing the adafruit nRF5xx boards and making the nessessary modifications to boards.txt and adding to the variants folder.

I have done this multiple times and have not got close to anything working, i've not found anyone else on the internet with this issue.

Any help would be much appreciated.

Re: Cant seem to get sparkfun nRF52840 mini to work with arduino IDE

Posted: Wed Mar 27, 2019 12:11 pm
by robwag
What IDE version are you using? for me 1.8.7 worked & 1.8.8 didn't so I went back a version and I recently updated when 1.8.9 came out and that's working fine so far. Also make sure the nRF52 by Arduino is "Not installed"

I have several projects with these boards working well.