SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Audio category should be posted in this forum.
User avatar
By Masa
#208430
Hello, I noted that the playback length of my WAV trigger is shorter than the stored wav file. I analyzed the sound generated from a speaker connected to the WAV trigger and it was consistently ~0.96s across trials even if the wav file is exactly 1.00 s (44.1kHz, 16bit, stereo).

Is it a usual behavior of WAV trigger, truncating a wav file during playback? I also heard that WAV trigger cannot loop without a break.

Thank you,
User avatar
By robertsonics
#208439
Are you running the latest version of firmware? Version 1.31 fixed a problem with files being truncated. Please see the release notes on the download page.

When looping, the WAV Trigger will always have a slight gap (of silence) between the last sample in the file and the first. This gap depends on the length of the file and can be anywhere from 0 to 128 samples, so up to around 3 ms.

FYI, Tsunami does truly seamless looping regardless of the length of the file. The last sample in the file is followed immediately by the first.
By cdw2000
#208441
Hi Jamie, I noticed that the V1.32 FW you made for me last year never got up on your Robertsonics WAV Trigger downloads page. You might recall that you changed the Attack/Fade algorithms so they would start/stop at a lower volume setting than in your V1.31 FW. Others might prefer that change as well. Thanks, Chris.