Page 1 of 1

High pitch whine with papa soundie + noisy cricket + 0.5W speaker

Posted: Sun May 12, 2019 9:44 pm
by eddieparker
I have a pretty simple circuit of a papa soundie board, a noisy cricket and a 0.5W speaker hooked up. It plays music fine using the example sketch, but there's a high pitched whine behind it that I can't seem to isolate.

Is there any troubleshooting steps I can follow to try and clear up the noise?

Re: High pitch whine with papa soundie + noisy cricket + 0.5W speaker

Posted: Tue May 14, 2019 1:14 am
by 142victoria
Hi eddieparker, I have had a similar problem to this, when using a Tsunami wav player. This turned out to be a problem of lack of isolation between the power supply to the board and the amp.
Refer to the post
“Tsunami Wav Player - noise issue” for the full discussion. I hope this helps.

Re: High pitch whine with papa soundie + noisy cricket + 0.5W speaker

Posted: Tue May 14, 2019 9:25 am
by TS-Mark
Hi everyone,

That is exactly what we were thinking, 142victoria. It is most likely either a ground isolation issue or possibly a "noisy" power supply.

There are a couple of things you could try and identify where the issue is originating from. First, try powering just the Papa Soundie via USB and connect some headphones to the 3.5mm jack on the board. Listen to the tracks through the headphones and see if you hear the "whine"/interference. If you do hear it there, it might be something to do with the audio files themselves. This is the least likely thing but it's the easiest to test.

The next step would be, as 142victoria suggests, to make sure you have isolation between your power supply. Here's a direct link to that post.

It might also just be a noisy power supply that is causing the issue here, too. If you have another way to power the circuit, give that a try and see if that helps reduce the noise here.

I hope one of these suggestions helps you resolve the issue here. If you still have issues after trying these suggestions, please take a few photos of your boards and circuit and attach them to your reply and we can continue troubleshooting.