SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Audio category should be posted in this forum.
By Creepy
Tsunami WAV Board - Stereo Mode - Receiving on MIDI Channel 01 (Although can dupe this in Omni Mode also)
Sending MIDI on CH01 from Ableton via Roland Duo-Capture MIDI Out or Roland UM-ONE MkII MIDI Interface
Two files on the SDCard: 0001_S1 KICK.wav and 0013_S3 SNARE.wav
Both audio files have been edited in Audacity to include NO meta data (and verified...several times)
This was first attempted using only 2 WAV files: KICK and SNARE for MIDI Note #'s 1 & 13 respectively. See Troubleshooting Notes below.
I'm using firmware 1.08s (properly renamed to tsunamix.hex on the SD Card)

Here's the weird bits:
- Sending MIDI Note 000 via Ableton with either interface triggers 0001_S1 KICK.wav as expected outputting via the expected output.
- Sending MIDI Note 001 via Ableton with either interface triggers 0001_S1 KICK.wav not as expected. Whut?
- Sending MIDI Note 0013 via Ableton with either interface does not seem to trigger 0013_S3 SNARE.wav
Note: All Notes are 1/4 Notes sent at 120BPM

The Blue LED:
- When not playing anything, or playing anything other than MIDI Notes 001, 002, 014 it remains 'usually off with occasional blink'
- When playing MIDI Notes 001 and 002 the Blue LED remains solid
- When playing MIDI Note 14 the Blue LED Pulses with the Note On's
Note: The SNARE wav is a shorter audio sample. So, is the Blue LED indicating that an audio file is being played or MIDI data is being rec'd? Kind of a moot point, but perhaps salient info for troubleshoting.

- MIDI Note 001 will trigger wav file 0001_S1 KICK.wav and send it to Stereo Output 1, which it does
- MIDI Note 002 will NOT trigger wave file 0001_S1 KICK.wav, although it *does* play 0001_S1 KICK.wav and sends it to Stereo Output 1
- MIDI Note 013 will NOT trigger 0013_S3 SNARE.wav, nor does the Blue LED exhibit any difference in behaviour between MIDI Note 013 and no input and/or no audio file to play
- MIDI Note 014 will NOT trigger any audio file (none exists for 0014), but the Blue LED behaviour is similar to when it triggers the Kick audio file successfully except that is is mostly on with short off periods corresponding to the shorter audio sample and the ON status of the LED corresponding to the MIDI trigger, so the assumption is that the Tsunami is attempting to play an audio file.

Troubleshooting Steps:
- Verified I have everything connected as correctly as I can barring any brain farts.
- Thinking there might be some undocumented file name requirements, I have tried different naming conventions after the initial tags to indicate Note Number, Single/Looped, Output, etc.
- Thinking maybe it's barf'ing a little because I want my Kick on MIDI Note 001 and Snare on 013 and there are no data files from 2-12, I created Blank audio files "00nn_S2 BLANK.wav" (where nn = 0002 to 0012)
- Verified via Audacity that audio files have no metadata.
- Verified which Tsunami firmware I'm using (by reinstalling and doing the [User]+[Reset] sequence as documented on
- Also tried sending MIDI data from a hardware sequencer (specifically Squarp Pyramid) which yields the exact same results as sending the MIDI from Ableton

tl;dr -
- MIDI Note 1 Triggers sound file 0001 as expected
- MIDI Note 2 Triggers sound file 0001 unexpected
- MIDI Note 13 does not trigger sound file 0013 (unexpected)
- MIDI Note 14 seems to want to trigger something, but not getting audio output
- Blue LED indicates the Tsunami wants to trigger for MIDI Note #s 1,2, & 14.

Curious question: The documentation seems to indicate that the Tsunami starts MIDI Note #s at "1". Does it start at "0"? (0-127 v 1-128) I'm thinking maybe the firmware thinks "Oh, there's no file for MIDI Note 0 so I'll just play the lowest one, and I'll play the same file for MIDI Note 1" (Where MIDI Note #'s start at 0 instead of 1) and for the Snare issue I'm getting confused in all my outputs - or maybe have the outputs wired or constructed incorrectly. (Stereo outputs are 1-4, so "nnnn_F3 filename.wav" outputs to 3L&R - hey, it's gotta be something stupid I'm overlooking, so why not ask where my brain fart might be...?)
Update: Well, getting the SNARE file to play. Not sure what I did, since I've been messing with files and trying different things.

Updated info:
- MIDI Note 14 triggers WAV file 13
- MIDI Note 1 triggers WAV file 1
- MIDI Note 2 triggers WAV file 1
Sorry, More:

Triggering the WAV files via the trigger inputs (using a wire) yields expected results:
01 Triggers WAV file 0001
02 Triggers WAV file 0002
13 Triggers WAV file 0013
All as expected.

The weird bit is happening when triggering with MIDI.
MIDI Note 001 triggers WAV file 001
MIDI Note 002 triggers WAV file 001 (again)
MIDI Note 003 triggers WAV file 002
MIDI Note 013 triggers nothing
MIDI Note 014 triggers WAV file 0013
Ugh. sorry.
I really don't know how to troubleshoot this. Apologies for the piecemeal cr*p. [eyeroll]@me

So, I copied the KICK and SNARE wav files to 0129_S1 KICK.wav and 0141_S3 SNARE.wav

Then via MIDI I sent a PgmChg to access the second "bank" of 128 MIDI Notes on the Tsunami.
MIDI Notes 1 & 13 yield nothing.
MIDI Notes 2 & 14 yield Kick & Snare sounds as expected.

Resetting the filenames to 0128_S1 KICK.wav and 0140_S3 SNARE.wav yield expected results triggered by MIDI Notes 1 & 13 respectively and no duplication of the Kick wav file triggered by MIDI Note 2.

So in the first bank (Bank 0 or Bank 1 depending on how you/Tsunami look at it), playing MIDI Note 1 and MIDI Note 2 yield the 0001 audio file played - everything is then shifted up one note (ie, MIDI Note 14 plays file marked 0013)

Incrementing the Bank and copying the same files yields semi-expected results except that MIDI Note 1 plays file 0128. This by itself would indicate to me the Tsunami indexes from '0' and that MIDI Note 1 should play file 0, but if I make a file such as 0000_S1 KICK.wav it does not play at all.

Although this is confusing (apologies) and way too many posts from me (sorry again), there is something strange with playing audio files in the first bank. I have a workaround for now (putting all my files on the second bank, which is fine because I doubt I'll ever have 4096 discrete audio files to play (famous last words)), but I'd like to know if I'm possibly doing something wrong or have a major brain disconnect that is messing with my ability to access 128 files in the first bank via MIDI Notes 1-128.
Yeah - that's a lot to wade through. Not complaining - I always appreciate when people provide detail. But if I just read the end, it sounds like the issue is that MIDI bank 1, note 1 should play track 0000, but doesn't, since that's not really a valid trackname number. Instead, bank 1, note 1 plays track 0001 as does note 2.

It sounds like a bit of an oversight (i.e. bug) to me - sorry you had to go through all that confusion. I'm not sure there's an easy answer. Perhaps I can make 0000 be valid track, but it wouldn't be available to any trigger function, only to MIDI and only in this one instance.

In the meantime, I hope you can live with just not using MIDI Bank 0 if indeed you need the full 128 notes in the bank.
Hey, thanks for the response.
I was just bopping back in here to update with some more info.

I'm freakin amazed, humbled, and honoured you dug through that whole thing and were able to follow the evolution of my bass-ackwards troubleshooting steps! LOL Really: I was also going to edit down to the salient points since I've gone from WTF to "Oh, this is happening and duplicatable, etc", but i couldn't find an Edit or Delete option for phpBB.

Actually, if triggering one file off is a 'feature' (heh), I can work around it. It is seeming consistent - as long as I know what file will be played when I 'do a thing' then I can adjust as necessary. (4095 samples instead of 4096?!? waaaah! LOL)

So as it stands:
- MIDI Note 1 triggers File 0001
- MIDI Note 2 also triggers File 0001
Subsequently, everything is shifted up - that is, MIDI Note 13 Triggers File 0012.
I don't think it needs to access a FIle0000 if I'm understanding your "Perhaps I can make..." statement. I'm just used to switching back and forth between 0 and 1 in MIDI because some parameters (patch #, Note number, CC's, etc) are sometimes 0-127 v 1-128 depending on the manufacturer. I never remember which mfr uses which, I just know to check it when I get strange results.

Notes (just because I went thru the steps):
- This morning I was testing different versions of the firmware. I tested 1.04s-1.08s and all yielded the same result.
- Last night I reformatted the SDCard to verify it's FAT32, copied the data over, same result.
- Just in case it's an SD Card issue, I'm using a Kingston Type 10 32g card. I know that one isn't specifically on your list, but the other Kingston Type 10 cards were rated 'yes' - and it's tougher to find 16g or lower cards these days.

I worry more that I'm doing something wrong on my side, which usually yields an uglier mess down the road.
Thanks again for your response
Sorry, one more bit:

I have file [0012_S3 SNARE.wav] among others.
When triggered via MIDI Note 13, it goes to Audio Output 1 and not 3.
I just noticed that as I was trying to move forward.

The "off by one", i.e. Note 2 triggers File 0001, is the intended behavior. I just never accounted for anyone ever using Bank 0 Note 1 - you may be the first person ever to do so. It was an oversight on my part, but not easily fixed. If I change the mapping to one-to-one, it will break things for everyone who as ever used MIDI. If I allowed a File 0000, and fixed the bug, then it would work, but as I mentioned, since Trigger 1 maps to File 0001, that file would only ever be available to MIDI. I'll add this to the list of outstanding issues.

Regarding the 0012_S3 SNARE file, that seems strange. A couple of questions: Mono or Stereo firmware? Are you using the most current firmware? Does mapping that file to other outputs besides 1 work? Can you map other files to output 3?
robertsonics wrote: Fri Feb 22, 2019 4:59 pm I just never accounted for anyone ever using Bank 0 Note 1 - you may be the first person ever to do so.
I get that "you may be the first person ever to do it" a lot.
Sorry. ;)
It's usually followed by "why the heck would you want to do that?!?".
robertsonics wrote: Fri Feb 22, 2019 4:59 pm Regarding the 0012_S3 SNARE file, that seems strange. A couple of questions: Mono or Stereo firmware? Are you using the most current firmware? Does mapping that file to other outputs besides 1 work? Can you map other files to output 3?
- Stereo. I can try the Mono firmware, but I have to wake up to make the WAV files.
- Most current: Yes 1.08s, correct?
- I only have Outputs 1,2, & 3 wired and have tried on 2 and 3. The file "0012_Sx SNARE.wav" where x=2 or 3 is still output on 1.

This smells of me doing something stupid, I'm just not sure what.
Is this another thing that I may be the first person to do? Really?
Okay, I hadn't noticed this before (ie at the very beginning of this thread) because of the way I'm using the Tsunami, but yes:

No matter the output defined in the filename, the output is always going to 1.
Firmware 1.08s

Filenames in use for this testing purpose:
0001_S1 KICK.wav
0002_S2 KICK2.wav
0128_S1 KICK (KICKS2b-35).wav
0140_S3 SNARE SLICES Something Tester.wav

As far as I get, those should be output 1,2,1,3 respectively.
The file naming conventions seem pretty straight forward, but did I miss something?
OKAY! GOT IT! >happy dance!<
Something something file naming conventions - wot?

Changing filenames to ONLY:

Where 'nnnn' = File Number/Note Number reference, F=S or L, and N=Output works exactly as expected.
Putting anything after that forces it to Output 1. Wot?


So, documentation is a bit inaccurate on two points:
"Starts track number T, where T = (MIDI Bank Number * 128) + MIDI Note Number."
T=(MIDI Bank 1 * 128) + MIDI Note Number 1 = (128)+1 = 129 yet it plays T=128


Under "3. Wav files and Tracks" where it says "The remainder of the filename does not matter and long filenames are allowed."
Well, I'd leave the rest of that bit out...?

Is this just for me or have other people run into this?
At least all this blah-blah-blah is on here in case anyone searches for the info.

Just putting that down and walking away. :)
Yah, I think if I run across anyone trying to do something similar to what I'm doing, first thing I'll recommend is to simplify the filenames.

I have so many samples and so few brain cells I was trying to use the filename to reference the source & processing techniques.
Still, I consider this a minor thing and it gave me a bit of confidence to be able to troubleshoot and find a solution/workaround, so win-win IMO. :)

In reading other posts on this forum re: the Tsunami, I didn't see a lot of q's about MIDI.
Are you using MIDI to trigger samples for music performance/production also?
Have you run into any other issues?
[Insert a bazillion questions about your rig and how you interface with hardware because I'm a systems person and that info is like crack to me] LOL
When you use long filenames, i.e. longer than 8 characters, FAT uses multiple directory entries, and replaces the last character in the first directory entry with a special character. This is not normally a problem when Tsunami and the WAV Trigger only need to look at the first 3 or 4 characters for the track number. But when you use Tsunami's ability to map MIDI sounds to outputs, that feature uses more characters. Turns out that using a long filename overwrites the last important character and so Tsunami doesn't recognize it. The answer is for that these sounds only, you need to not use long filenames.

It's absolutely my fault that I didn't realize this when you mentioned the problem - I simply forgot. Sorry you had to rediscover the issue. Point taken, and I'll try to do a better job of documenting this.