SparkFun Forums 

Where electronics enthusiasts find answers.

Everything ARM and LPC
By k_505@hotmail.com
#144620
I am designing a breakout board for the STM32F103RB, I have the UART1 pins out so I can use flash programming rather than JTAG, but I am having no luck with ST flash programmer :( it gives me different problem messages..
1) "Unrecognized device...please, reset your device then try again"
2) "No response from the target, the boot loader can not be started. Please verify the boot mode configuration and the flash protection status, Reset your device then try again"
3) "Cannot get available commands, please, try to change echo selection, reset your device then try again"

Board:
====
I have a custom made board, which I confirm is working since I have the JTAG pins out as well and was able to connect and program it using Olimex ARM-USB-OCD + Eclipse

Connection:
=======
USB to serial FT232 --> Sparkfun logic level converter (3.3v/5v) --> STM32 UART pins

Settings:
======
Boot 0 = 1
Boot 1 = 0

Things I tried:
=========
1 - Set boot 0 & boot 1 to correct setting (As above) then quickly pressing next button on flash demonstrator
2 - Power up board, run flash demonstrator, pressing next
3 - Power up board, run flash demonstrator, press reset button, pressing next

Nothing of that works, for some reason the Flash demonstrator does not want to connect to the board :(

Appreciate your input on this...
By motopic
#144664
Do you have the ft232 driver installed (i should add for the chip id you have installed onto your pcb)?
Is you r ft232 chip operating correctly?
Do you have a known ft232 usb->uart dongle that you could wire up to the uart using flywires?
By hsutherl
#144788
According to the source code in Sloadhost (see below) the autobaud character is 0x7f, or DEL, and the response is 0x79, or 'y'. So in theory you should be able connect with a terminal program, reset the board, hit (or hold down) the DEL key, and see a 'y' in response.

When I tried this on a commercial dev board I did get a response, but it wasn't a 'y' - it was more like the sort of garbage you expect to see with wrong baud rate, etc. Same thing at 57600 or 115200. I only tried 8n1 - that might be my problem. More research required. (Sorry - too lazy to dig through the ST docs right now.)

Anyway you might try that and see if you're getting anything at all from the STM32. A scope or even a multimeter might help.

Search this topic for "sloadhost" - Alex Faveluka's program has been very useful for me, but diagnostics are not its strong point, and I'm not sure it includes a Windows binary.

[Edit]The terminal program I tried first ("screen") was sending a 4 character sequence when I hit the DEL key. Hence the garbage. It turns out that HyperTerminal can be set to send DEL (0x7f) when you hit the backspace key. Using that method I was able to get the 'y' response. However, forget what I said about holding the key down - it seems to be a one-time thing.

I think this is the first time I've ever written anything positive about HyperTerm!
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]