Loading program into Internal Flash with uVision4

Everything ARM and LPC

Moderator: phalanx

Loading program into Internal Flash with uVision4

Postby evmiller » Mon May 16, 2011 1:07 pm

The other day I loaded a pretty simple example LED blinking program into flash memory using Keil's uVision4, with an AT91SAM7S256. I made a few changes to the program, and now for some reason I am unable to load it back into flash memory. I'm not really sure what the problem could be, as I haven't changed any hardware setup. The program I am trying to load simulates properly on this chip, it just doesn't seem to want to load into the internal flash. Any suggestions? I've tried changing the JTAG speed with pretty much the same result. Here is the output that uVision is giving me:

VTarget = 3.267V
Info: TotalIRLen = 4, IRPrint = 0x01
Info: TotalIRLen = 4, IRPrint = 0x01
Info: RTCK seems to be bridged with TCK
Info: Auto JTAG speed: 8000 kHz
Info: Core does not stop after Reset, setting WP to stop it.
***JLink Warning: PC of target system has unexpected value of 0x00000004 after reset.
DLL version V4.24b, compiled Feb 22 2011 20:47:17
Firmware: J-Link ARM V8 compiled Apr 27 2011 20:42:35
Hardware: V8.00
Hardware-Breakpoints: 2
Software-Breakpoints: 2048
Watchpoints: 0
Found 1 JTAG device, Total IRLen = 4:
Id of device #0: 0x3F0F0F0F
ARM7 identified.
JTAG speed: 8000 kHz
Info: TotalIRLen = 4, IRPrint = 0x01
Info: TotalIRLen = 4, IRPrint = 0x01
JTAG speed: 12000 kHz
Erase Done.
Programming Failed!
evmiller
 
Posts: 6
Joined: Fri May 13, 2011 10:32 am


Return to Everything ARM and LPC

Who is online

Users browsing this forum: No registered users and 5 guests