LPC2478 ISP Problem

Everything ARM and LPC

Moderator: phalanx

LPC2478 ISP Problem

Postby SushilR » Tue Apr 13, 2010 4:14 pm

Dear All,

I am currently facing a problem with programming LPC2478 using ISP.
I m getting the following message everything i try to program LPC2478
Operation Failed. Failed to autobaud - step 1.

I have connected serial port to UART0 of LPC2478
The serial cable connections are as follows:
1-1, 2-3, 3-2, 4-6, 5-5, 6-4, 7-8, 8-7... pin 9 is not connected
While programming the LPC2478, I have put the jumpers ISP_E & RST_E whereas RST_SW1 is kept open

In the Flash Magic,
1. Select Device: LPC2478
COM Port: COM1
Baud Rate: 9600
Interface: None(ISP)
Oscillator(MHz):12

2. Erase all Flash+Code Rd Plot is ticked

3. Hex file is selected

4. Verify after programming

I click on start and then power up the LPC2478 board.
after sometime, the message "Operation Failed. Failed to autobaud - step 1." is popped up.

Can someone help in solving the problem.
Regards
Sushil...
SushilR
 
Posts: 14
Joined: Wed Dec 09, 2009 7:54 pm

Re: LPC2478 ISP Problem

Postby SushilR » Mon Apr 19, 2010 6:17 am

Dear All

The ISP Problem has got solved.

I tried sending 3F to the board using Hercules(hyperterminal) software.
3F was received back on Hercules(hyperterminal). This confirmed me that the board is working properly.

I was powering up the board little late after "Start" button is clicked on Flash Magic. The problem was with resetting the ARM chip.

Thank you.
Regards
Sushil...
SushilR
 
Posts: 14
Joined: Wed Dec 09, 2009 7:54 pm


Return to Everything ARM and LPC

Who is online

Users browsing this forum: No registered users and 1 guest