SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Qwiic category should be posted in this forum. To learn more about Qwiic, consider checking out our pillar page on the Qwiic system.
Hello! I'm using the Qwiic scale system, connected to a load cell. The Qwiic scale itself is connected to an arduino nano via the Qwiic connector -> 4 cable converter.

I'm having an issue where after running any program using the Qwiic scale (including the provided examples) the Arduino hangs indefinitely after about 30 seconds or so of the scale functioning properly. From my research, I'm fairly certain that this is due to a design choice in Arduino's 'wire.h' library, where it polls the I2C pins on a while() loop, and if it loses connection to the I2C pins at any point it will hang forever. I've tried alternative I2C libraries that support a timeout, but that's beside the point, those don't work either.

I've re-soldered all my connections, and tested for connectivity so I'm fairly certain it's not an issue with the connection - i've done the ol' wire wiggle test while the scale is working, and wiggling the wires doesn't cause the arduino to hang. I've also added additional output to output the program run time, and the Arduino isn't hanging after a consistent length of time, it seems to be random.

I've tried swapping out the Qwiic scale device itself, that's not the issue either!

Any insight would be greatly appreciated c:
Hi Jackson.

Sorry for the delay in getting back to you!
I've not been able to duplicate the issue you're having and I'm using the example code we provide with the default Arduino wire library. I'm beginning to suspect you may have a bad NAU7802 chip on your board. Can you PM me your order number or invoice number? Once I have that, I'll be able to assist more. :-)