SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Qwiic category should be posted in this forum. To learn more about Qwiic, consider checking out our pillar page on the Qwiic system.
We are aware of the issues associated with the Lightning sensor failing to initialize. We are currently working with the development team associated with the product and are working on a fix.

We are still not entirely sure what the issue is and some of the fixes that have been mention in the threads in this topic are not 100% guaranteed to work, however, we have had some success in-house with the following:
  • 1st, Try an I2C scan and make sure that the lightning sensor is responding with 0x03 indicating that the I2C connection is working.
  • Try pulling MISO and CS to ground. Do not use digital low for this and use the GND line on your controller instead. This may require soldering
  • Try the new library we had put out and use the specific I2C example. You may also try the SPI example as that has been more consistent and functional as of now.
  • If using a Qwiic connector system try confirming that the Qwiic cable is making a solid connection with the Qwiic connector on the controller board and lightning sensor
You may also try bypassing the Qwiic system altogether and going straight to I2C pins if you think the Qwiic system is suspect, however, if the Qwiic scan returns 0x03 than there is no issues with the Qwiic system.

If you have tried all of the above and things are still not working, provide a photo of your setup and as much information as possible in the LIGHTNING DETECTOR UNABLE TO INITIALIZE thread. We will review it and try to figure what what the next step is.