SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Qwiic category should be posted in this forum. To learn more about Qwiic, consider checking out our pillar page on the Qwiic system.
User avatar
By buffler
#207369
SOMETIMES the mp3 player quits playing a track in mid-track. Only sometimes. And it happens with two different new mp3 players. Can an MP3 track have more than one EOF? If so, why doess the anomalous stop only happen sometimes? I am COMPLETELY BAFFLED!
Thanks
User avatar
By TS-Chris
#207409
Hello Buffler.

Is it always the same track doing this and do other tracks do the same thing? If it's always the same track, there may be an error somewhere in the file that causes the player to crash. Not sure what would make it happen only some of the time though.

You might try re-recording the bad track and see if that fixes things.
User avatar
By TS-Chris
#207541
I'm kind of wondering if the board doesn't like your SD card.
Can you try a different card that's 16GB or less in size? You might also try formatting the card with the SD Card Associations formatting utility too just to make sure the file system on your card is correct.

I've attached some known good tracks to test with as well.
You do not have the required permissions to view the files attached to this post.
User avatar
By TS-Chris
#207551
Certain cards have quirks that cause problems when used with some devices. I don't know if this applies to the MP3 Trigger, but I know some cards are troublesome on the WAV Trigger. (See this page for more information on that.)

Generally when users have issues like yours, a different brand and size SD card fixes the issue and sometimes reformatting the card with the SD Card Association formatting utility helps as well.