SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Programmers category & general programming devices should be posted in this forum.
#203199
Following the guide to hookup the 340G to my laptop to access my Simultaneous RFID Tag Reader.
I have tried this with MacOS Mojave 10.14.4 and Windows 10 ( Bootcamp ).
MacBook pro mid-2014 laptop.

I've tried two different CH340G's, Two different USB cables, and even tried this on another MacBook Pro ... and so It's not likely a cable or port hardware issue unless I'm really unlucky.

I can see 5V of power output from the breakout but the port is never recognized by the OS so I can't perform the hardware test through a terminal.

I've rebooted several times, reset PRM. Sigh.
#203200
Have you made sure that you are using the right driver? You can try to update the driver to version 1.5. There are instructions in the hookup guide. However, if you have a driver version issue, usually, the OS runs into a kernel error and cause the OS to constantly reboot.

Otherwise, make sure you aren't using a charging only cable. You can test the cable with a digital device, like a phone. If you can see your phone/device on the computer when connecting with the USB cable, then it allows data to pass through. If your computer doesn't recognize your phone as a device, then it is a charging cable and only passes power... which would be why you get 5V, but your computer doesn't recognize the CH340 chip.