SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Programmers category & general programming devices should be posted in this forum.
#207053
I connect my MCU (3.3 V) to an RS232 device. I got the right output voltage on each side. And there is communication between them. But I did not get the right answer from the RS232 device. Is the board broken?

The code works well with a previous self-made max3232 board with the maxim max3232 Do I need to add a resistor to the pins T1IN and T2IN on the board? Since we have the resistors on the self-made board
#207055
Hello yaoz.

There should be everything on the board it needs to function and it only requires power and connection to your system. Can you provide some photos and a schematic showing how you have the board connected? Maybe we can spot the issue from those.
#207092
Hi TS-Chris,
The board is connected exactly as the hookup-diagram from the product side.
I used an oscilloscope to read the signals on RX and TX. What weird is that the oscilloscope shows the correct answer (on the pin R2OUT) from the RS-232 device. But the MC shows a totally different value for the same signal. I am sure that there is no problem with the MC and the program since they work well with our self-made board.
Do you have any ideas about the reason? Thank you.
#207099
We don't have a hookup diagram for this product so I'm unable to understand what your setup looks like.

There is a possibility you have a bad board, but I'm unable to determine that from the information given. Can you please provide some photos and/or a schematic showing how you have the board connected to your devices?

Here's a high level overview of how signals flow through the board:
11189-1.jpg
Here's an example of how you would connect the board to a RS-232 and TTL circuit:
11189-2.jpg
You do not have the required permissions to view the files attached to this post.
#207140
The problem is solved. I added a pull-up resistor to the pin TIN, as the following schematic shows. And it works now.
[attachment=2]BOB-11189 hookup-revised.jpg[/attachment]
I would be nice if you can provide a new version with pull-up resistors in the future. Maybe the current board works with Arduino, but it does not work with my MC (Infineon XMC4500). And our self-made board (with the pull-up resistor) also worked well with Arduino.

For someone who may know the reason why it does not work without the pull-up resistor, I will explain my previous hookup and investigations in following.
The board is connected previously as follows:
[attachment=0]BOB-11189 hookup.jpg[/attachment]
However, it does not work with my MC. I read the TTL OUT signal from an oscilloscope. I was the desired answer (e.g. 0x4F) from the RS-232 device. But the interpreting from the MC is different (it turns to be 0x46 or some other values).

Then I made another test to connect the RS232 Out to RS232IN:
[attachment=1]BOB-11189 hookup - invest.jpg[/attachment]
And the MC can receive exactly the same signal as the one it sends out.

I have no idea how does it happen. Maybe you can give an explanation.
You do not have the required permissions to view the files attached to this post.
#207153
I'm glad the resistor fixed the issue for you. We have not had to use a resistor to get these to work and have never had a customer state they do too so I'm not sure what could be causing that issue for you.