Search found 4 matches

by 6L20_akw
Mon Jan 08, 2018 5:23 am
Forum: General Chit Chat
Topic: Autodriver V13/ steppers not completing large movements and stopping on continuous rotations
Replies: 6
Views: 1489

Re: Autodriver V13/ steppers not completing large movements and stopping on continuous rotations

Thanks again for your reply. I finally found the solution; PWM modulators are indeed used for voltage compensation (see section 9.1.10 of the datasheet), using the KVAL. My power supply si 12V, motors have a nominal 2.4V. I set up my acc and run kval at 51 (255 would be 12V, no compensation, 51 is t...
by 6L20_akw
Tue Jan 02, 2018 1:01 pm
Forum: General Chit Chat
Topic: Autodriver V13/ steppers not completing large movements and stopping on continuous rotations
Replies: 6
Views: 1489

Re: Autodriver V13/ steppers not completing large movements and stopping on continuous rotations

Isn't it why the driver uses PWM to drive the steppers, to get the max available torque using a "too high voltage" ? From what I learnt, all steppers have low coil tensions, and the driver must know how much current it "sends" to get the maximum torque without heating too much, and thus uses PWM. Wh...
by 6L20_akw
Tue Jan 02, 2018 4:57 am
Forum: General Chit Chat
Topic: Autodriver V13/ steppers not completing large movements and stopping on continuous rotations
Replies: 6
Views: 1489

Re: Autodriver V13/ steppers not completing large movements and stopping on continuous rotations

Thanks for your reply! I don't have much info on my Chinese steppers , just got these values :2.4V, 1.7A ,1.5 ohms resistance and 3.2mH inductance. They should be compatible shouldn't they? I could not find a precise guide explaining how to set the Octhresh, running kval etc to the proper values giv...
by 6L20_akw
Thu Dec 28, 2017 4:31 am
Forum: General Chit Chat
Topic: Autodriver V13/ steppers not completing large movements and stopping on continuous rotations
Replies: 6
Views: 1489

Autodriver V13/ steppers not completing large movements and stopping on continuous rotations

Hi all. I have my 4 autodrivers V13 hooked up and working properly with an arduino mega, just a weird problem is occuring : the steppers never complete large movements or continuous rotations: If I use mystepper.run(FWD, 300) once for example, it runs for about 2 seconds then stops. If I put the fun...